Board not booting up


#1

Greetings;

I got a DragonBoard410c as i was interested in the coursera IOT course, and when i first tried plugging it in (with a 2A 12V adapter), a blue LED flashed, then nothing.
I checked everything, but it simply isn’t booting up. when i reconnect it to the adapter, nothing.
I tried later, different adapters (but all same amp/voltage), still not booting, and sometimes the blue LED flashes.

any help? is the board faulty? can it be salvaged?

Thanks in advance.


Dragonboard 410c Boot Problem
#2
  1. Make all the switch s6 is all off (0-0-0-0)
  2. Make sure the HDMI cable is plugged in and the HDTV is turned on before powering on the DB410C.
  3. Make sure the OTG micoUSB is not connected if you want to use a USB keyboard and/or mouse on the host USB ports.
  4. Note: if you use a USB hub to the DB410C, you may have to un-plug and re-plug the USB keyboard and mouse from the hub after boot up to be recognized. At least that happened with my IoGear mini-hub.

Did you look here:
Basic Kit: Getting Started
I assume you have the Basic kit, since it doesn’t come with a PS.

The Basic kit is supposed to have Android pre-installed.
Do you know if your board is on Android or Debian Linux?

(For me right now, user LED #4 is blinking green, but I re-flashed to Debian Linux)

BTW, I’m also taking the Coursera IoT classes.
Quickly powered through course #1 (powered through in 3 days since no on-hands, the last module was entertaining).
Course #2 (where I’m at currently), needs a little updating and some minor corrections, but still useful.

Alex M.


#3

Ok, I just re-did the SD install of Android build #99 (Lollipop 5.1.1).
I did not flash the latest Android build #118—it failed when I did it the first time.
I see none of the LEDs come on when Android boots.
Note: it takes a little less than a minute for Qualcomm’s logo to appear, then it goes black, then about 2 minutes later, the Android screen pops up.
Then that will go back to black in a minute if there is no mouse/keyboard input—Android screensaver set to 1-minute timeout.

The blue LED only comes on when I turn on the Bluetooth–a steady blue, not blinking even when scanning for other BT devices.

You might want to try an SD card install of Android or Debian (at least it blinks a LED).
Or drop it into fastboot mode and see if you the fastboot tool “sees” something.

Just note: I ran into a problem when I re-used the uSD card I had used to do an SD image install of Debian. Even though I re-flashed it with an SD Android image, when I put it in the DB410C it said it was re-flashing Debian again. I did it twice, making sure I picked the right image and checking the write protect on my SD adapter carrier was off.
I eventually did a ‘dd if=/dev/zero of=/dev/mmcblk0 oflag=sync bs=1G count=8’ to zero it out.
Re-flashed SD Android image onto it again, that finally worked. Weird.

Alex M.


#4

One final thing (I need sleep), I was shutting down Android by holding down the power button (S2) for ten seconds, which seems to do reboot instead, I did see the green LED (user #4) flash for a little bit.
#4 eventually went dark after Android came back up, then blue BT LED came on (since I had left Bluetooth turned on in the Android settings, default is off).

Alex M


#5

Thanks guys for all the help, but this was the first time booting it. I never got anything to appear on the screen. I tried plugging/unplugging the keyboard/mouse. I made sure the switches were all set to zero. I nearly tried anything. (I even hooked it to a computer, with the right switch configuration but not with fastboot, nothing. Didn’t even light up the leds)

Also, when I said the blue LED flashes, I mean it lightens up once for less than a second, then goes dark.

I only got the board, not the basic kit.

I just wish it’s a software issue or something, I fear the hardware is damaged… How can I test for that?


#6

What display device are you using? The Android builds use a fixed video mode and are pretty fussy about what display devices thay will support.

IIRC Android doesn’t have any blinking LEDs lit up by default so the board going dark is normal, and if your display cannot lock on the signal from the board its very hard to figure out what it might be doing.

Another trick is to try re-installing Android from SD card (note that the installer uses the same GFX stack as our debian images and supports a much wider range of monitors):
http://www.96boards.org/db410c-getting-started/Installation/README.md/


#7

hi guys, thanks for the wonderful comments.

Unfortunately, i researched a bit and came across this:

https://social.msdn.microsoft.com/Forums/en-US/de7a60e0-a22f-4fa0-8395-9a779c3f5e0b/dragonboard-410c-bt-light-on-overheating-and-no-display?forum=WindowsIoT

this is exactly what happens (with the exception that the BT LED only blinks instantaneously instead of being on)

it seems that i need to return it, which is almost impossible since i got it a while ago (last august), and i don’t live in the US.

I honestly have no idea what to do…


#8

I’m not clear if if you have tried and failed to recover using an SD card or if you are reaching a judgement solely going upon the behaviour of the BT led and absence of display?


#9

frankly i haven’t tried recovering from an SD Card, it’s next on my to do.

is there any other way to provide power to the board without the adapter?


#10

Make another quick control:
Be sure your power circular plug is of the correct size and diameter. I, as well as other, ran into that problem in the past.
The plug MUST be the right size otherwise it may make a sporadic contact.
See link below:


Jean-Marc


#11

Thank you so much. i am actually using A DVI to HDMI cable.
I tried many variances of the power circular plug, none worked. i will try to get the plug specified exactly.


#12

i am actually using A DVI to HDMI cable.

Are you able to try connecting the device to a “real” HDMI device such as a TV? When I said the Android build is pretty fussy about display devices I do mean it… some DVI-D work but most don’t!


#13

To avoid confusion: I am talking about the circular plug from the power supply and should be 4.75 x 1.75mm and nothing else. If this one is not exactly the size you might have a bad connection.

I am not talking about the HDMI :slight_smile:


#14

Hello,

@danielt I am having issues with doing anything on my dragonboard since a couple of days ago, when the bluetooth and wi-fi light turned on and since then, whenever I power the board, the light automatically turns on. Not only does it turn on almost immediately, but the board begins to get pretty hot to the touch, and there is nothing displayed via the monitor. The bluetooth and wi-fi both light still turns on every time, without display and no used led turned on .

Has anyone had a similar problem? Please let me know!

Thank You in advance !!!