DragonBoard 410C - (Almost) No sign of life out of the box


#1

Hey guys.

I’m having a lot of issues with my new DragonBoard 410c, and I hope that someone knows what to do :slight_smile:

I’ve have never been able to boot it - or at least, all monitors I’ve tried haven’t received any signal from the DBs HDMI port. No LEDs are flashing and I haven’t seen any sign of life since I pulled it out of the box. On very few occasions, I’ve seen a blue LED flash for 0.1 s when I plug in the power, but no life sign beside of that. I’ve been very careful when handling it, making sure not to bend the board, only connecting power as the last step and being careful not to damage with ESD.

What I’ve tried so far:

  • different monitors (TV and PC monitor)
  • different power adapters (12V 1A),
  • regular boot from the chip
  • booting from the SD card with both Android ver. 99 and v. 118.

Have anyone experienced the same or knows what to do?

Thanks in advance, guys!


DragonBoard 410C wont start
Board not booting up
#2

Have you tried flashing Linaro it has better (stronger) video signal than Android. With Linaro I could connect to both a high quality TV with a straight through HDMI cable and to a monitor using a HDMI to DVI-D adapter cable. With Android (version 99 worked best) I could connect to TV with high quality TV straight through HDMI cable but NOT to a monitor using a HDMI to DVI-D adapter cable (I tried three cable brands the Android drivers just aren’t good enough to handle an adapted signal).


#3

As mentioned cgramona the Android version 99 is safe to use and never gave particular problems.

But once you tried this and still does not work did you check your power supply connector on the dragonboard connector?
A lots of user had this problem in the past, the connector, if not the correct size might not make a good contact.
I recommend to use the specified one 4.75 x 1.75mm and nothing else.

Hope this help.