Dragonboard 410c Boot Problem


#1

Hello,

I’m a new user of Dragonboard 410c. I prepared every component ( HDMI monitor, usb keyboard etc.) and plugged in the device with and adaptor of 12V 2A. Firstly the BT LED flashed for less than a second and after a few seconds LED 4 turned on. Then I saw the android os on the screen and there was no problem, it worked fine.

I wanted the use Ubuntu Core on the devices and did some research. I found the installation on the official website of the Ubuntu. The link is as follows:
https://developer.ubuntu.com/core/get-started/dragonboard-410c

I did everthing in order. I wrote the Ubuntu Core into an 8 GB micro SD card. I turned the switch S6 as 0-1-0-0 and put the other cables and finally plugged in the device. But I had a problem that device again opened the Android OS. There was no boot screen or other things. I also tried the S6 as 0-1-1-0 as mentioned some videos. I thought that the problem was about the SD card but I also wrote Ubuntu Core for Raspbbery Pi 3 into SD card and with the same components, it worked fine and run the Ubuntu Core.

In the next day, I tried the booting device in SD boot but I had the same thing. Again Android OS opened there was no boot screen etc. After a few tries, Android OS didn’t come up but also boot screen didn’t come up. Then I tried the S6 as 0-0-0-0 but there was nothing in the screen and Android OS didn’t come up. When I plugged the device, there is only BT LED flashes for a moment and nothing happens after that. I measure the voltage values and a 12 V at the socket. There is 1.8 V in the 35th pin etc. Problem is not in the power, sd card and monitor beacuse they worked fine in the Raspberry Pi 3. I don’t know what to do. I did some research and found few person that has the same problem. Their links are in the below:


I should also mentioned that I tried the fastboot mode and my PC didn’t see the Dragonboard.

I would be very happy if anyone can help me. Thanks for all.


#2

If we are worried about whether the hardware works or not it would be better to test with the debian builds rather then the (third party) Ubuntu boards. Once you are confident in the hardware you can switch to Ubuntu as you wish.

The best way to install debian is to use the SD Card Method - Install and boot from eMMC.


#3

@danielt Thank you for your contributions.

I tried to install debian a few hours ago but the result was the same. Nothing happened during the procedure. I did everything in order in the link that you sent. I really stuck in this situation. Is there anything can I do.

I also wanted to ask you about if there is a reset mode of the device or something. For example a combination of the buttons that reset the OS of the device or something like that we can see a bios or bootloading screen. I’m also thinking that there maybe a software problem in the device. It would be very helpful the reset the device’s software.


#4

Do you have a serial uart/console ?

You should see some messages, at least from the ROM boot code (PBL), something like this:
S - QC_IMAGE_VERSION_STRING=BOOT.BF.3.0-00286
S - IMAGE_VARIANT_STRING=HAAAANAZA
S - OEM_IMAGE_VERSION_STRING=CRM
S - Boot Config, 0x000002e3
S - Core 0 Frequency, 0 MHz
B - 1547 - PBL, Start


#5

Hi @Vuvuzela

Based on the symptoms you have described I suspect that you have not used the right process to put the image onto the SDCard. The DragonBoard requires a specially formatted card, you need to use the program Win32DiskImager (or dd on a Linux system) to transfer the image onto the SDCard.

The hint you gave is the face that you were able to go back and test the SDCard on a Raspberry Pi. But I know from experience that once you have correctly placed an image into the SDCard it is VERY difficult (but not impossible) to reformat the SDCard back to a FAT file system.

Full Disclosure: I am an employee of Qualcomm Canada, any opinions I may have expressed in this or any other post may not reflect the opinions of my employer.


#6

For writing images to SD cards, I have found Etcher from resion.io a far more reliable tool.

More details at:


#7

Hello, I am so sorry for this delayed answer because I was waiting for the components.

@Loic Thank you for your advice. I tried the use the UART serial console for getting infromation but nothing showed up. Serial console and the USB UART converter works fine beacuse I used them for other devices and there is no problem. What can I do right now? Is there any option for me the resetting the device?

@ljking Thank you for your advice. I bought a new Sandisk SD card and wrote the image into it by using Etcher that is adviced by @barryb. But again there was no boot screen and nothing showed up. The problem is not about the SD card. There is no signal come up from device. How can I access the device?

Thank you for your contributions.