"getty: bad speed: 1500000" Error


#1

Dear All

I successfully compiled yocto project with core-minimal-image configuration and yocto deployed an core-image-minimal-rock960-rk3399-gpt.img then I burned this img to a sdcard, and tried for booting from it.

But i get below error message.

"Sat Dec 1 13:09:28 UTC 2018
[ 5.281985] random: nonblocking pool is initialized
INIT: Entering runlevel: 5
Configuring network interfaces… ip: SIOCGIFFLAGS: No such device
Starting syslogd/klogd: done
getty: bad speed: 1500000
getty: bad speed: 1500000
getty: bad speed: 1500000
getty: bad speed: 1500000
getty: bad speed: 1500000
getty: bad speed: 1500000
getty: bad speed: 1500000
getty: bad speed: 1500000
getty: bad speed: 1500000
getty: bad speed: 1500000
INIT: Id “FIQ0” respawning too fast: disabled for 5 minutes
"

Do you have any sugestion?

B.R.


#2

Can you share the full kernel log (e.g. via pastebin)?


#3

http://pasted.co/59646731


#4

From this topic I understand you changed the speed to fiq debug speed to 115200: Changing UART Baudrate to 115200, I suppose (no device-tree doc) it modifies the tty max speed and leads to this issue.

From your log I see:

Retrieving file: /extlinux/extlinux.conf
reading /extlinux/extlinux.conf
200 bytes read in 2 ms (97.7 KiB/s)
1:      yocto
Retrieving file: /Image
reading /Image
18657288 bytes read in 1175 ms (15.1 MiB/s)
append: console=tty1 console=ttyFIQ0,1500000n8 rw       root=PARTUUID=b921b045-1d rootfstype=ext4       init=/sbin/init rootwait

I think you have to edit /extlinux/extlinux.conf and change console=ttyFIQ0,1500000n8 to console=ttyFIQ0,115200n8.

then not sure the device tree change is even requested.