Fastboot error with rb3

Hi everyone,

I am trying to open fastboot mode. I typed adb reboot bootloader command. After that I can see this logs from com port :

EFI Total : 800 ms
POST Time      [ 3217] OS Loader
Loader Build Info: Dec 21 2020 22:30:13
VB: RWDeviceState: Succeed using devinfo!
Press <Down> to enter fastboot, <Up> to enter recovery, or <ESC> to enter EmergencyDLOAD
Recovery command: 32 bootonce-bootloader
KeyPress:0, BootReason:2
Fastboot=1, Recovery:0
GetVmData: making ScmCall to get HypInfo
GetVmData: No Vm data present! Status = (0x3)
VM Hyp calls not present
Launching fastboot
Fastboot Build Info: Dec 21 2020 22:30:12
qusb2_1: hstx: 7
PLL1 locked: 5
usb_lane: 1
Fastboot: Initializing...
Fastboot: Processing commands
Fastboot Action (Press <Right> to select): SAT
Dev_EventError: EfiUsbMsgBusEventResume not allowed in state DEV_STATE_DEFAULT_ADDRESSED
Handling Cmd: getvar:product
DwcUpdateURB:Trb: TRB ring of EpIndex 2 is full
UsbfnDwcSubmitUrbNode: UpdateUrb Failed: 0x8000000B
UsbfnDwcTransfer: Failed to submit transfer
UsbDeviceSend: Failed to submit data transfer: Device Error
Error, failed to handle USB event
Exit key detection timer
Press any key to shutdown

now fastboot devices command returns nothing. why is that ?

@274_4194 hello sir , did you ever figured this out ? got the same issue here

Hello, I tried with another pc. fastboot devices commands returns my device with new computer and I typed fastboot reboot. after that it started to work with both of computers.

Hey , thanks for the response . I tried that it kinda worked , fastboot devices show up the device but still I could not send commands it got stuck similar to what you posted there

Hello, did you try recovery ?

Actually on windows fastboot works properly , idk why on linux it gives me that error . I think it is something related to udev rules , but I did applied as they instruct on manual. I am able to flash images now aosp/debian but I got no HDMI output now lol

I am sorry, I dont know much about hdmi. but one possible solution can be vysor for android.

No worries . Let me ask you do have a stable build/manifest for this board either android or linux?

I compiled aosp source code and flashed it. please refer AOSP/db845c - Linaro Wiki.

Yeah I did that as well but I got no hdmi outputn, even tho the system boots properly I can adb shell to it and everything.
Do you happen to have those binaries with you ? Or the manifest / workspace ?

sorry but I dont have binaries. but I used android-12.0.0_r2 branch for aosp by using this command :
repo init -u -b android-12.0.0_r2
and 5.4 branch for kernel by using this command
repo init -u -b common-android12-5.4

Did you add this patch to you kernel build ?
Thanks for sharing

Actually no. I did not try hdmi output because I am using vysor.

I see , that`s actually a good idea , but either way I built kernel with that patch and copied the artfacts to device/linaro/dragonboard-kernel and hdmi works and build aosp, but I used current mainline for both kernel and aosp because that patch is already merged into kernel mainline commit 2a9df204be0bbb896e087f00b9ee3fc559d5a608 in kernel/common repo.
Thanks a lot