Dragonboard410c Debian #283 - disabling kernel messages to /dev/ttyMSM0 (/dev/console)


#1

Hi all,

I need to use both UART0 and UART1 for communication with an MCU.
However, UART1 is attached to the Linux system console /dev/console.

I already disabled the login commenting the line:

ExecStart=-/sbin/agetty --noclear %I $TERM --keep-baud 115200,38400,9600

which disables root autologin via sytem console (root login is enabled by default).
However, I would like to disable all messages which are forwarded to /dev/ttyMSM0 by default, including boot messages and kernel messages.

Following the instructions given here and here , removing the

console=ttyMSM0,115200n8

from the kernel command line, doesn’t do trick.
After flashing the boot image with fastboot, kernel messages are shown as always, boot messages also.

What it the correct way to completely disable the kernel messages logs to /dev/ttyMSM0 ?
I could accept boot logging, but after that I would like to have the /dev/ttyMSM0 free of kernel messages and login (I actually only accomplished to disable login/autologin).

Thank you in advance for your help.
Regards,
Simon


ttyMSM1 and data loss in Debian
#2

I suggest you to remove stdout-path from chosen node in the device-tree (arch/arm64/boot/dts/qcom/apq8016-sbc.dtsi). Then regenerate your boot image and let me know…

If it does not work could you please share the content of your /proc/cmdline.


#3

Yes ! Thank you @Loic, now works fine.

Regards,
Simon


#4

Yeah… Removing kernel parameter removes the console messages but still kernel will output some boot messages because of earlycon which will get disabled after following @Loic’s suggestions.