Can not recognize keyboard and mounse with Android build 206 and 207


#1

The pre-installed Android system can recognize the keyboard and mouse, I feel the system response speed is slower, and the wifi+bluetooth module is very hot without the use of WiFi ;

I think the reason is system optimization is not in place early, then I download the latest official image file to brush system, after brush finished and started android system, ocured the folowing problem:

the mouse and keyboard light does not shine, insert the U disk and no response;

The computer connect to the hikey960 via ADB , enters the ADB shell command line, executes the lsusb, the result is null, and uses the 360 telephone assistant can install the software to the android system;

Installation process environment information:

Before installation, the system appeared to have been built in April 5th

The host system for the installation is Debian, and the hardware is bublegum96

How can I resolve this problem?

Thanks!


#2

Is this for the hikey960 or bubblegum96?
Can you try removing the adb connection and check the keyboard and mouse again? I think similar to the hikey (Android on 96Boards FAQ), the keyboard/mouse and adb cannot be used at the same time.


#3

Bubblegum96 is the host machine when falshing system;
I removed adb connection(type-c) when start android,someone in QQ group also told me that type-c takes precedence over usb;
This morning I tried build 208 of AOSP and resulte the same problem(USB no electricity);
I also downloaded hikey960-linaro-2017.04.24-factory-3803d63e.zip but failed to flash,I can not download other Image becuase it may succeed only before work hours;


#4

This time I flashed the earliest available Image(build 110,hikey960-linaro-2017.04.24-factory-3803d63e.zip),the USB Type-A still not work;

I also buyed USB hub with type-c connect to hikey960,plug mouse and keyboard to the hub,it works;

So the problem is the USB swicher can not swich from type-c to type-a,it became an hardware problem?




#5

The usb lighten when I replaced the HDMI line,that is the 1.4 version of HDMI;
So it seems that HDMI became ome of USB swicher that 1.4 version anable USB work and 2.0 version close USB.
But I do not know why the HDMI (idifferent version) is the USB swicher?


#6

@flowas Are you saying that the USB A connections work when you have HDMI v1.4 connection, but doesn’t work when you have HDMI v2.0 connection? Can you please submit a report to https://bugs.96boards.org with your analysis/findings, referencing this thread? Thanks!


#7

Yes, you get it right;A bug is reported:
https://bugs.96boards.org/show_bug.cgi?id=564


#8

Thanks for this problem & the answer !
The problem happen to me , make me confused!