Android on 96Boards FAQ

Q: Can I use mouse/keyboard and adb at the same time?

Very good question, it would be great if it could you the mouse/keyboard and adb at the same time.
The current 96Boards has two USB Type A connectors (the two big regular USB connectors) and one micro USB connector.
To use adb from your host PC, you need to connect the Host PC with micro USB connector.

Not all SoC used on the 96Boards have more than one USB OTG ports. The Dragonboard 410C and HiKey are sharing one USB port with switch between USB Type-A ports and micro USB ports. With this design it is not possible to use both USB Type-A connector and micro USB connector at the same time.

You need to unplug anything it is connected on the the USB Type A connector, such as, mouse or keyboard and etc, to use micro USB connector for adb.

Using any mouse/keyboard and other USB devices on regular usage of Android is perfectly fine,
just please remove any USB devices on both Type-A connector before inserting micro USB cable for starting to use adb.

Q: Why does Android showing on the display disappears and stops?

When booting the Android and the screen goes to blank after about a minute, it scars you as if the board have died.

This is standard behaviour of the Android just going into the sleep, as usual Android phones and tablets.
To awake the Android, inserting the keyboard and typing any key should go out from the sleep mode.

Q: How to collect debug log on Android when having the issue?

Happy for the question. The detail procedure to reproduce the issue and the debug log are essential for reporting the problem.

Just do:

adb shell dmesg > dmesg.log
adb logcat -d 2>&1 > logcat.log

Attach both dmesg.log and logcat.log.

If you have any ideas of topics that we should cover in the FAQ then feel free to post below (or send me a PM).

How can you access the GPIO from Android?

[Edit after reading some more]

It looks like libmraa has java bindings, would this be the best/easiest way to add GPIO control from Android?


See below thread for more info.

How to program Seeed Sensor Board when using Android with DragonBoard 410c?

how can we interface a new LCD display with DragonBoard through high speed gpio pin?

Hi @Akira,

I’m using a JACK P2 soldered on J7. To play and record audio I use the follow commands on the command line:

tinymix ‘MultiMedia1 Mixer TERT_MI2S_TX’ 1

tinymix ‘DEC1 MUX’ ‘ADC2’

tinymix ‘ADC2 MUX’ ‘INP2’

tinycap /data/test.wav

tinymix ‘PRI_MI2S_RX Audio Mixer MultiMedia1’ 1

tinymix ‘RX1 MIX1 INP1’ ‘RX1’

tinymix ‘RX2 MIX1 INP1’ ‘RX2’

tinymix ‘RDAC2 MUX’ ‘RX2’

tinymix ‘HPHL’ ‘Switch’

tinymix ‘HPHR’ ‘Switch’

tinymix ‘MI2S_RX Channels’ ‘Two’

tinyplay /data/test.wav

But I want to start up the DragonBoard with these configurations. I’ve tried to modify the file ‘mixer_paths_sbc.xml’ but I didn’t succeed, may you know how I can start the system with these configurations. Should I modify any boot file? Could you help me?


@Vitor Pacheco:

I have done some things with initialization files on the DragonBoard 410c running Android.

There is a post boot script I was told to work with and had success using. (

  1. From a host machine, you will need adb setup.
  2. root system, pull file, modify, push, reboot.
adb root
adb remount
exit out of shell
adb pull /etc/
  1. Use your favorite text editor to edit post boot script (add your modifications to bottom of the script, save, quit.)
adb push /etc/
adb reboot

After reboot, wait until board is completely booted up to ensure your script was run.

This has worked for me with GPIO setup on Android. You might run into permission issues when pulling and pushing the init files, be sure to set permission as needed.

I hope this helps!!!

If you are still having problems, please bring your issues to OpenHours. I am there every week for a live broadcast to help answer questions like these in person, with developers from all over the world!

Hi @Robert Wolff,

Thanks for your reply.
I’ve been doing your team course on Coursera and I’ve done these configurations for GPIO.
I thought the init.qcom.post_boot was just for GPIO settings and honestly, I don’t know why didn’t I try this before.
But thank you, I tried and It’s working now.

I’m trying to follow OpenHours and if I have more questions, I’ll be glad to share with you.

Thanks so much,


@Vitor Pacheco:

I am very glad to hear of your success!!! It would be nice to have you in OpenHours! These next few weeks we will be doing a DragonBoard 410c mini-series and giving away DragonBoards! :smiley: invite your friends or workmates and friends.

We will also have the DragonBoard 410c creator on the call, he will be answering all questions related to DB410c.

I hope to see you there.

Keep in touch!

Thanks @Robert Wolff,

I’ve now another problem, when I use the Music app from Android, I can play musics and listen it with my headset, but when I use the Sound Recorder app, the microphone doesn’t work and it records nothing. I think I should modify the microphone as primary, but I don’t know how. Do you know what I could do?

I noticed that when I start the DragonBoard the JackP2 audio configurations are right, but when I try to use Sound Recorder, it changes the recording configurations.

Thank you in advance.

i have created one kernel module.and compiled in android source code…but whenever i will try to load that module in dragonboard showing error:
insmod: failed to load svs_driver.ko: Required key not available.
I searched on google also.but i didnt get.what is the problem with my module.
please Help.

Hi All

anyone know the latest Android base code Version On the 410C board?
How can i download the latest Version code?

Thank you everyone in advance


Have you been to the DB410c documentation landing page? You can download latest image there, ready for flashing.

I would recommend using the sd card image.

I hope this was helpful. If you still have questions, please bring them to OpenHours this week:


Hi Team,

Do we have pre-built binaries available for Dragonboard 410C on Android Nougat. If available Please share the link


Hello, @vinay

Pre-built images for DB410c can be found here:

The release notes can be found here(for latest):

QC Android build is currently on Marshmallow as noted on page 6 of release notes.

As you may know, 96Boards and Linaro do not play a part in building nor advancing these images.

Currently, I am unsure as to the progress with Android on the DragonBoard 410c. I will try to check on this and try to update you as soon as I get some information.

Please feel free to join us on 96Boards OpenHours every week. Bring your questions, and we will try to get you answers in real time on our live conference call.

Hope this helps!

Thanks @Robert. It has been a very quick response.Please let me know when you have an Android nougat update on Dragonboard410C.

I really like the DragonBoard 410c, but I’m interested in running Android and am becoming concerned about the viability of Android on this platform. Robert, as you have pointed out, the Android builds are coming from Qualcomm and it’s apparent that the quality is, how shall we say, suspect. As I understand it, are the actual “releases”, while are the builds that could become releases in the future. Please clarify this for me if I’m wrong. The latest release from Qualcomm is now six months old, and shows off the phone app crashing continuously right from boot up. Yes, I found some instructions on this forum to stop the messages, but the phone app continues to crash repeatedly. This sure doesn’t give me the warm fuzzies about Android on DragonBoard 410c, so I need to look elsewhere. Unfortunately, the “elsewhere” means either switching operating systems, or going away from 96boards altogether. I’m hoping that I’m wrong and someone from Qualcomm will point out where to get the stable build of Android for the 410c, but it seems if they had that it would be up on the site. Also, while we’re at it, maybe someone from Qualcomm could point out where the release and/or build notes are for the snapshot builds? are the actual “releases”, while are the builds that could become releases in the future

shows off the phone app crashing continuously right from boot up
This is fixed in

Thanks for the confirmations. I installed snapshot build 128 this morning, and sure enough, the phone app crashing problem is gone. There is however another continuous error condition reported, something trying to run the sdcard command with usage problems.
I think the largest concern is the state of support of Android for the DragonBoard 410c. The link from the DragonBoard 410c product page in the 96boards site to the Android download references build 99, which is Android 5.1.1. On the same page, the apparent companion link to the release/build notes accesses a build note for Android 6. That could be release build 118, but that has the crashing phone app problem. Snapshot build 128 fixes the crashing phone app but the release notes from the DragonBoard 410c product page in the 96boards site don’t match it either, although they are a lot closer. Plus, the Build from 96boards (build 118) was done in July, with nothing since other than the snapshots, which suggests that at best the build schedule is very infrequent.

Perhaps someone can answer a few questions which might help the developer community:

  1. When will a more stable Android build be available via the path?
  2. Could the release/build notes be packaged with the download (inside the zipfile) or at least in the download page (e.g.
  3. What actually is the optimal site (URL) for getting the best Android builds for the DragonBoard 410c? Is it through 96boards, through Qualcomm, or through some other site?