Building AOSP - lunch command fails


#1

I’m trying to build AOSP for the dragonboard 410c and everything goes fine until I run lunch as detailed in https://www.96boards.org/documentation/consumer/dragonboard/dragonboard410c/guides/aosp.md.html.
It throws this error:
*** Unknown ARM architecture version: armv8-a. Stop.

** Don’t have a product spec for: ‘db410c32_only’
** Do you have the right repo manifest?

I also tried using just db410c32_only, which returned another error saying that it was an invalid lunch combo. Anyone know a solution to this, or have I done something wrong?


#2

@pundiramit i haven’t tested this yet, but is 410c still maintained? Is it building on you end?


#3

Interesting. I didn’t see this error before. May be something new in AOSP is triggering this build failure. I’m travelling this week. I’ll get to it when I get back. Also I do expect build to fail due to recent external/bison project change, which got fixed last week but the prebuilts AOSP project (prebuilts/build-tools) need to be updated too. I’ll follow up on that too. Thanks.


#4

Ok, I just tested this, not getting the error on my end. But the build fails while compiling mesa
https://paste.ubuntu.com/p/ygN57M7xf5/


#5

Yeah I was talking about the same build error above. It is fixed in the bison source but the prebuilt/build-tools need to be updated too.