Android 8 image and google services on 410C


#1

hi folks. I’m new at this forum and interesting, will it be available some day android 8 release with google services from the box? I’m planing to make the tablet based on 410c. I bought one and tested with android 5.1, it looks old and slow and no google market apps, even they woun’t install. Hmmm. Please share your oppinion.


#2

There are two Android options for DB410C.

There is the Android port provided by the SoC vendor which you have evaluated. This is based on the production Android ports and we do not expect any further updates.

The alternative is to build AOSP yourself. This leverages (amoung other things) the extensive upstreaming work done alongisde the GNU/Linux builds and some glue logic to implement the Android hw_composer using mainline graphics interfaces (DRM) and IIRC will give you something that is broadly similar to Android 9. This is essentially a skunkworks project for us so getting this up and running requires some effort and regressions are common. However there is some documenting to give some clues on how to get started:

Note that neither option will include Google Play Services since DB410C does not have the required license from Google (please do not discuss technical workarounds for this on this forum).


#3

hey Daniel. Thanks for the clarification. Appreciated.


#4

Hi folks. This is would be interesting for some of you, who tried build AOSP based on link above.

The proprietary package has been downloaded successfully, then after the compilation some warnings appear and ONE fatal error that has caused the compilation (missing file):
_xmlpool.h:103:10: fatal error: 'xmlpool/options.h' file not found_
Soo, downloaded the patch from here:
https://patchwork.freedesktop.org/patch/169798/
with hope that would help, tried to patch it. Patch didn’t response.
BTW started compilation again.
Compiled! after 3 hours with remark: “Some targets has not generated” something like that…
It’s time to flash! Fastboot is Ok->Flashing->everything is OK except systeme.img (it’s absent from the OUT directory, it hasn’t not compiled on my PC in some reason) I’m using UBUNTU 16.04 LTS.

Did anyone has build AOSP and flashed the DB410 successfully with this release?

Thanks
BR Mik


#5

In file included from external/mesa3d/src/mesa/drivers/dri/common/dri_util.c:45:
external/mesa3d/src/util/xmlpool.h:103:10: fatal error: 'xmlpool/options.h' file not found
#include "xmlpool/options.h"
         ^~~~~~~~~~~~~~~~~~~
**1 error generated.**
[  4% 3135/69314] target thumb C: libGLES_mesa <= external/mesa3d/src/egl/drivers/dri2/egl_dri2.c
In file included from external/mesa3d/src/egl/drivers/dri2/egl_dri2.c:42:
external/mesa3d/include/xf86drm.h:66:6: warning: variable 'ver' is used uninitialized whenever 'if' condition is true [-Wsometimes-uninitialized]
        if (nbr_filters > 0 && filters == NULL)
            ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
external/mesa3d/include/xf86drm.h:122:17: note: uninitialized use occurs here
        drmFreeVersion(ver);
                       ^~~
external/mesa3d/include/xf86drm.h:66:2: note: remove the 'if' if its condition is always false
        if (nbr_filters > 0 && filters == NULL)
        ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
external/mesa3d/include/xf86drm.h:63:6: warning: variable 'ver' is used uninitialized whenever 'if' condition is true [-Wsometimes-uninitialized]
        if (fd < 0)
            ^~~~~~
external/mesa3d/include/xf86drm.h:122:17: note: uninitialized use occurs here
        drmFreeVersion(ver);
                       ^~~
external/mesa3d/include/xf86drm.h:63:2: note: remove the 'if' if its condition is always false
        if (fd < 0)
        ^~~~~~~~~~~
external/mesa3d/include/xf86drm.h:69:2: note: variable 'ver' is declared here
        drmVersionPtr ver = drmGetVersion(fd);
        ^
2 warnings generated.
18:24:56 ninja failed with: exit status 1

#### failed to build some targets (02:38 (mm:ss)) ####


#6

I can concur that when building AOSP I get the same error during compilation.

_xmlpool.h:103:10: fatal error: 'xmlpool/options.h' file not found_

I read in a different post in this forum that Rob keeps a test or WIP of some of the patches or tree. I’m not exactly sure cause haven’t looked into it deep.

It is under the generic device.

Now I have another Idea that i am going to test.
I have a Galaxy Tab E SM-T560NU which has similar chipset msm8916.

There are some lineage ports for the Tab E and i will try to run one of these ports on the Dragonboard 410.

I’m sure the boot image will need some tweaking and i plan to use the kernel from the stock DB rom. Hopefully it’ll boot and if it does it might not take a whole lot to get everything fixed. I really don’t know. I think it would be a good starting point anyway.

The one I’m going to try is for this device.
SM-T560NU - gtelwifiue

Here is a link to the thread where the rom is posted. All source code is available as well as pre-compiled binaries.

https://forum.xda-developers.com/galaxy-tab-e/development/unofficial-lineageos-16-0-galaxy-tab-e-t3847488

If were lucky maybe we will have Lineage OS 16.0 / Android PIE running in no time.

This port runs on the galaxy tab with Lollipop bootloader set so i’m hopeful that it will be fairly easy to get it going on the dragonboard.


#7

I saw the same error when building for DB820C but for me it was transient and disappeared when I relaunched make. I haven’t really investigated but this sort of problem is usually caused by a missing dependency in the build system.

As a hack you might be able to work around the problem by increasing the number of jobs, maybe make -j16 and retrying a couple of times when you get the compile error.