Yocto mplayer2 commercial whitelist issue


#1

Hi,

I am using dragonboard 410C, and I’m trying to get Mplayer2 to work.
mpalyer refuses to compile due to it’s commercial license:

… was skipped: because it has a restricted license not whitelisted in LICENSE_FLAGS_WHITELIST

I have already tried adding to rc.local:

LICENSE_FLAGS_WHITELIST = “commercial”

(did not work)

ant other idea?

thanks!


#2

hi,

you need to have “commercial_mplayer2” in LICENSE_FLAGS_WHITELIST, not ‘commercial’


#3

Sorry, still doesn’t work.
any other ideas?


#4

hi,

right. A small oversight on my side. This variable is ‘set’ in meta-rpb/conf/distro/include/rpb.inc, so whatever is put in local.conf will be ignored. I just fixed this issue in master branch, see

Alternatively, you can do in local.conf

LICENSE_FLAGS_WHITELIST_append = " commercial_mplayer2"

It should set it properly.

However after fixing this, you will end up with another issue:

ERROR: Nothing PROVIDES 'mplayer2’
ERROR: mplayer2 was skipped: Recipe is blacklisted: Not compatible with currently used ffmpeg 3

Which is because of this:

http://git.openembedded.org/meta-openembedded/tree/meta-oe/recipes-multimedia/mplayer/mplayer2_git.bb#n158

That needs to be investigated…