Yocto gstreamer support


#1

Hello,
I am trying to add gstreamer to Yocto,
I have added the following packages:
gstreamer1.0
gstreamer1.0-plugins-base
gstreamer1.0-plugins-bad
I am trying to play h264 movie and it gives missing plugins.
Different ones for different movies.
Is there HW support for h264 in gstreamer?
Should i add something else to the CORE_IMAGE_BASE_INSTALL?
Thank you


#2

hi,

I suppose that you are using the meta-qcom BSP layer, as per https://github.com/96boards/documentation/wiki/Dragonboard-410c-OpenEmbedded-and-Yocto.

Gstreamer plugins for DB410c video playback exist, but we haven’t added the OE recipes for that in this layer yet. In fact someone submitted a pull request with the support, but I have not had the time to look into it yet:

I am planning to work on the meta-qcom a bit in the coming days/weeks, with the goal to have ‘feature parity’ compared to our latest Debian release. So that will include adding/merging the Gst support , among other things.

If you can try the pull request and provide feedback/test in the mean time, please let me know.


#3

Hello,
currently is is not working:

  1. I have added the Gstreamer layers to the image:
    gstreamer1.0
    gstreamer1.0-plugins-base
    gstreamer1.0-plugins-good
    gstreamer1.0-plugins-bad
  2. The suggested command line:
    gst-launch-1.0 filesrc localtion=<mp4 file> ! qtdemux ! h264parse ! v4l2dec ! videoconvert ! waylandsink
    Is not working, the v4l2dec plugin is missing. I think the correct one is v4l2video32dec
    I have replaced it with the v4l2video32dec and it looks that it is working, but the window on the screen is green.
  3. Tried to test waylandsink by:
    gst-launch-1.0 videotestsrc ! waylandsink
    It is fails with “Failed to connect to the wayland display ‘(default)’”

#4

hi,

are you saying that you tried with the pull request I mentioned and it is not working? the right plugin is v4l2dec and needs to be built (using the patch in the pull request) and added to the image.

It is not included by default in the current BSP layer.


#5

Hi,
It is not working after the patch:
The gstreamer package does not exist.
I have added gtreamer and plugins-bad,base,good and now the v4l2dec does not exist.
Thanks


#6

Hello @lLeonid,

Since february did you succeed with the command “gst-launch-1.0 videotestsrc ! waylandsink” without starting weston ?

Jérôme.