Xterm bug in Linaro - release 19.01 build


#1

Dear all,

Found a serious bug from recent Linaro release 19.01 build. ‘xterm’ and ‘htop’ cannot render font properly. Installed and tested from 19.01 (https://releases.linaro.org/96boards/dragonboard410c/linaro/debian/19.01/) and some more (490 - 488) (http://snapshots.linaro.org/96boards/dragonboard410c/linaro/debian/), but every builds have same exact issues. Would you let me know how to fix it?

htop
xterm


#2

This looks like it could be a problem in X11 client side rendering. Old school X11 applications perform font rendering server side (meaning they get the X11 server to render the characters). Modern applications (modern in this case meaning “less than fifteen years old”) typically perform the rendering client side in order to implement modern features such as anti-aliasing and these all look OK.

It certainly clearly a bug to I’ve pushed it to the tracker: https://bugs.96boards.org/show_bug.cgi?id=814


#3

As a temp workaround you can try to run xterm with xterm -fa mono.


#4

It’s not nice but you can also work around by preventing OpenGL from being used to accelerate 2D rendering. In principle this can be done by putting a config fragment into /etc/X11/xorg.conf.d but I haven’t worked out exactly how to do this so I used brute force instead (this is likely to be reversed whenever an apt upgrade affects the X server):

mv /usr/lib/xorg/modules/libglamoregl.so /usr/lib/xorg/modules/libglamoregl.so-disabled

#5

Yes, it works! Thank you Daniel! Thank you Loic!