Xen on Hikey970



Is Xen support available for this board?



Is Xen support available for this board?

In principle it should work. All the same components that xen relies on
for hikey960 are also available on hikey970 (and since xen itself
contains very few drivers it does not need to be ported for a particular
board… it works more or less the same on all arm64 platforms).

However I’m not aware of any tutorial information so it will be more
difficult to assemble to components than it is for hikey960.


Hi Daniel,

We tried to run Xen, but getting below log

Using modules provided by bootloader in FDT
Xen 4.7.6 (c/s Mon Jul 9 10:10:36 2018 +0200 git:280a556) EFI loader
Xen 4.7.6
(XEN) Xen version 4.7.6 (omkar.bolla@) (aarch64-linux-gnu-gcc (Linaro GCC 7.1-2017.05) 7.1.1 20170510) debug=n Sun Aug 12 15:15:06 IST 2018
(XEN) Latest ChangeSet: Mon Jul 9 10:10:36 2018 +0200 git:280a556
(XEN) Processor: 410fd034: “ARM Limited”, variant: 0x0, part 0xd03, rev 0x4
(XEN) 64-bit Execution:
(XEN) Processor Features: 0000000000002222 0000000000000000
(XEN) Exception Levels: EL3:64+32 EL2:64+32 EL1:64+32 EL0:64+32
(XEN) Extensions: FloatingPoint AdvancedSIMD
(XEN) Debug Features: 0000000010305106 0000000000000000
(XEN) Auxiliary Features: 0000000000000000 0000000000000000
(XEN) Memory Model Features: 0000000000001122 0000000000000000
(XEN) ISA Features: 0000000000011120 0000000000000000
(XEN) 32-bit Execution:
(XEN) Processor Features: 00000131:00011011
(XEN) Instruction Sets: AArch32 A32 Thumb Thumb-2 Jazelle
(XEN) Extensions: GenericTimer Security
(XEN) Debug Features: 03010066
(XEN) Auxiliary Features: 00000000
(XEN) Memory Model Features: 10201105 40000000 01260000 02102211
(XEN) ISA Features: 02101110 13112111 21232042 01112131 00011142 00011121
(XEN) Using PSCI-1.1 for SMP bringup
(XEN) SMP: Allowing 8 CPUs
(XEN) Generic Timer IRQ: phys=30 hyp=26 virt=27 Freq: 1920 KHz
(XEN) ****************************************
(XEN) Panic on CPU 0:
(XEN) GICv2: Cannot find a valid address for the hypervisor
(XEN) ****************************************
(XEN) Reboot in five seconds…


(XEN) ****************************************
(XEN) Panic on CPU 0:
(XEN) GICv2: Cannot find a valid address for the hypervisor
(XEN) ****************************************


GICv3 is pretty different to GICv2 and it looks Xen support for GICv3 is
relatively new (Arm shared a glimpse of a work-in-progress at the end of

It is possible that a newer xen will be needed (although it still won’t
be hikey970 specific) since the interrupt controller is one of the few
devices that Xen does implement drivers for within the hypervisor rather
than within dom0.

How to use Xen for linux(ubuntu) and Android

Hi danielt,
Do you know how this error solved?
Thank you!


Hi Ramblech,

We didn’t try to resolve this issue. You can try posting this issue to Xen developer community you may get help.


No, I’m afraid not.

I agree with @Vikram that getting involved with the Xen community is they way to move forward here.


Hi all,
I solve this error by modify kirin970.dtsi:
gic: interrupt-controller@e82b0000 {
compatible = “arm,gic-400”;
#interrupt-cells = <3>;
#address-cells = <2>;
#size-cells = <2>;
redistributor-stride = <0x0 0x30000>;
reg = <0x0 0xe82b1000 0x0 0x1000>, /* GICD /
<0x0 0xe82b2000 0x0 0x1000>, /
<0x0 0xe82b4000 0 0x2000>, /
<0x0 0xe82b6000 0 0x2000>; /
interrupts = <1 9 0xff04>;


Do you have more changes like these?
Would be good to have those in one place so we can all benefit.

Best regards,
Jan Rinze.