Wifi not working


#1

Hi All,
I have 2DB’s, and on one Wifi is not able to detect available networks. The OS is Android. Can someone please let me know how to debug further? I’m a newbie to Android.

regards
Venkatesh


#2

Hi Venkatesh

Instructions to setup Wifi on Android are described in the DragonBoard 410c Android User Guide (link) (see section 4.1). Its not clear from your post how far you get through these instructions before something goes wrong.

Take a look and let us know what happens!

Daniel.


#3

Hi Daniel,
Here is the sequence of operations that I did before Wifi stopped working.

  1. Default Android OS detected a Wifi network and I was able to connect to the same.
  2. Updated the DB with Win10IoT and again was able to detect Wifi networks and was able to connect to the same
  3. Reloaded Android onto the DB and voila Wifi doesnt detect any networks. Fuse the Win10IoT again and Wifi works properly.
    To confirm, I tried this on all the boards that I have and all gave the same problem. Once Win10IoT is fused, Wifi stops working (either doesnt detect networks or detects “ghost” networks) when I switch back to Android OS.
    My suspicion is that Win10IoT core is leaving the hardware in some zombie state that is persisted across reboots / flash updates.
    I would need pointers now to debug this issue -I’m now left with DB that dont work with Android!

Venkatesh


#4

So…

I tried repeating the steps you outlined above and I can’t reproduce any problem. Specifically I tried the following:

Anything different to the way you did it?


#5

Hi,

I recently got a Dragonboard. Installed Debian through SD Card. I am able to connect WiFi, but the connection is rather very unstable. Every now and then, I see the browser timing out due to missing connection. Many times, the pages are not loaded fully as the connection breaks. I don’t see any notification for disconnection.
Also, when I try to access my board over the network using a terminal application like Putty, I get a message saying, connection lost and the Putty terminal becomes unresponsive.

Can anyone please help?

Regards,
Nagendra


#6

Hi @nchaturvedi,

Yes, we are aware of the WIFI being disconnected periodically and in the middle of fixing the symptom.

You may try the temporary workaround described at the bellow link until it is fixed.
https://discuss.96boards.org/t/ssh-and-ping-workarounds

This is the link in bug tracking system.
https://bugs.96boards.org/show_bug.cgi?id=272


#7

The first link is broken


#8

I’ve updated the link… but (just like this one) the thread is very old and these workarounds are not needed for any current release.