Wifi LED blinking


#1

Hi!

My Dragonboard 410c wifi led is blinking (green light), probably to indicate when the wifi is working.

How to I turn it off, while leaving the wifi functionality on (as it is)? The product that I’m working on requires no blinking lights.


#2

Several possibilities:

a. You can remove the led (led@5) default trigger from the device tree (apq8016-sbc.dtsi) and rebuild your kernel image.

b. At runtime, on your board you can also use dt-update tool:

git clone https://github.com/96boards/dt-update.git
cd dt-update/
make && make install
dbootimg /dev/disk/by-partlabel/boot -x dtb | dtbtool -n led@5 -s linux,default-trigger="none" | dbootimg /dev/disk/by-partlabel/boot -u dtb 
reboot

c. Note that you can disable it from your host computer as well, just replace /dev/disk/by-partlabel/boot with your boot image and reflash the boot partition with fastboot.


#3

Or a simple way is to have the below line in init script:

echo none | sudo tee /sys/class/leds/apq8016-sbc:yellow:wlan/trigger

It will turn off the Wifi LED trigger during debian boot.


#4

Hi @Mani, I went to the command line (terminal) and did:

sudo echo none | sudo tee /sys/class/leds/apq8016-sbc:yellow:wlan/trigger

But nothing happened. ( I am on Dragonboard 410c with Linaro)


#5

But nothing happened. ( I am on Dragonboard 410c with Linaro)

It is supposed to turn OFF the trigger for Wifi LED. After executing this command, the Wifi LED won’t blink at all.

It is working at my end. What are the directories listed under /sys/class/leds/?


#6

@Nadav_B, are you sure it is the WiFi LED that is blinking? The WiFi lamp is near the middle of the board (and clearly labelled “WIFI”).

However by default there is also a flashing LED between the two USB type A socket (and labelled “1”). This LED flashes with a heart beat pattern (thump, thump, pause) and the BPM increases under load. Whilst the state can be hacked using a shell script it’s probably best to turn off this light from the DTB (as @Loic suggests, but substituting led@1 for led@5) rather than using an init script since I think it is likely to start flashing before the shell script runs.