WiFi does not work in Linux


#1

I burned the latest Linux SD card Image (Checked Checksum etc) onto an SD and booted up. It now boots linux but when I try to use Wireless it cannot connect. The WiFi Security password is set and it seems that the SW passes this stage because if I type in a wrong password it notifies me.

Do not know how to continue, did anyone had a similar experience?


#2

I have the same problem. I described it here:
https://www.96boards.org/forums/topic/wifi-dhcp-issue/

As mentioned in the above URL, switching to static IP helped although other strangeness with the wifi still remains.


#3

Same problems here. Using the Windows 10 IoT image, I can set and see Wifi is working. Still have no luck getting Android on the device so I can’t say if it works there.


#4

Indeed a static IP did solve the problem for me for now. Thanks for the tip. By the way WiFi did work for me using Android.


#5

Hi halo

Are you using an AT&T Uverse router by chance? My friend and I have the same problem and both are using AT&T Uverse router. I recently disabled the DHCP server on the Uverse router and started using the one the wifi access point instead. DHCP works likes a charm this way.


#6

Hi tdc,

I do use an AT&T router.

I will try to move DHCP to the router later today and report back on the results.


#7

Hi tdc

Got totally side tracked could not work on it for a few weeks, my apologies.

Got it to work also, thanks very much.