WIFI DHCP issue


#1

My friend and I got 410c’s. Both of us are having an issue with DHCP over the built-in wifi on Ubuntu. What’s common between our setup is that we use an AT&T-provided xDSL gateway.

Wifi AP’s system log shows authentication is successful, but 410c cannot retrieve an IP address from the DHCP server. If I manually enter an IP address, gateway, and DNS addresses, I can browse the internet, so wifi hardware must be alive. I have tried different snapshots/releases of Ubuntu with no luck.

I also tried another router, which is just my cellphone’s hotspot feature, and this one actually works fine. DHCP lease is successful and I can browse the internet.

Because of this problem, I am currently using a USB wifi dongle for which I managed to compile the driver (this was really painful), but I am wondering if other people are seeing the same problem and if there is any solution for this. I see that the built-in wifi has been behaving very strange as discussed here: https://www.96boards.org/forums/topic/410cubuntu-cant-ssh-in/ but not sure if this is related. I’m “guessing” that the known issue with the built-in wifi is causing a problem with a certain implementation of DHCP (like the one in my router).

Thanks


#2

Hi,

Are you still having problem with this issue? Have you tried disabling security features on the gateway and/or reserving an IP for your board’s MAC? Or is the IP Passthrough a viable option/alternative?


#3

A recent fix in the wcn36xx driver solved the problem. I tried Debian snapshot #51.

Thanks


#4

Glad to see that #51 solved this for you.

I have a similar problem on my db410c, where I can join networks but DHCP requests times out. In my case this is solved by a configuration change of the PMIC, that happens when I load the mdsp.

This piece of configuration was also integrated into the boot code in BSP 1.2.

So for others who have this problem, please try to load the mdsp and/or update your boot with the 1.2 BSP package.

Regards,
Bjorn