Wifi Band Steering not working


#1

When we connect the db410c to a router that is using Band Steering, the router think that the device is supporting 5ghz. This prevent the dragonboard to detect and connect to the router. (Band steering is a feature on enterprise routers to force 5ghz compatible devices to connect on the 5ghz wifi band)

In my specific case (EnGenius router), we only see a blank ssid when scanning. This only happen in Linux(oe/debian), Android have a different driver and is working correctly.

The wcn36xx is a generic driver supporting 5ghz and registring every 5ghz channels.

The first thing I tried was to remove that 5ghz band from the driver but still, the router see us as 5ghz compatible and prevent us to connect to 2.4.

We also tried to update the firmware to version 66 (extracted from android) with the same result.

Can any1 help with this, and maybe confirm that this is also a problem on other routers with band steering enabled ?


#2

Thanks for the report, it sure sounds like we’re advertising something incorrectly, so I have created https://bugs.96boards.org/show_bug.cgi?id=493 for tracking this.


#3

I have tested with 2 EnGenius and one D-Link AC1900 routers with band steering enabled,

The two EnGenious are doing the same problem BUT I was able to connect to the D-Link (Band Steering is named Smart-Connect in the D-Link).

So it looks like Smart-Connect is more “Smart” than EnGenious. Still there is a configuration problem in this driver.