WiFi and Bluetooh LEDs in Linaro 4.24


#1

I just received my DragonBoard 410C (packaged as an IoT kit for Amazon AWS) from Arrow. Connected keyboard/mouse/HDMI then power and it booted straight into Linaro-alip 4.2.4 (Dated Jan 8 2016). Aside from a very faint split-second blue flash of the ‘BT’ LED (nothing from the WiFi LED) at initial application of power to the board neither LED ever comes on. The other four status LEDs seem to function as they should. Should the BT and WiFI LEDs be showing activity? WiFi and Bluetooth work just fine once booted up although I noticed that after connecting to my WiFi LAN the Bluetooth is always turned-off upon startup into Linaro, but I can manually toggle it. The very first time I booted the board Bluetooth was enabled without me having to do anything at all. I’m not sure if that behavior is by design or not.

It looks like there have been quite a few updates to the Linaro image since Jan 8 and that I probably need to upgrade, but I thought I’d ask the above questions before I started throwing new images at the board. Other than some innocuous looking XML error that I have to click past every time I boot and the Bluetooth being turned-off at boot (and wondering if the BT and WiFi LEDs should be showing activity) the board itself seems to be functioning just fine. Haven’t tried to SSH to it, but I’m guessing that won’t work on the 4.2.4 Linaro-alip release based on some reading I’ve been doing on the forums here.

Thanks for your time.


#2

Looks like I’ll be answering my own question, in case someone else new to the DragonBoard 410c happens to wonder about the functionality/use of the BT and WiFi LEDs they won’t come-up empty handed when searching (like I did initially)

On the board I ordered from Arrow (the Amazon IoT/AWS package) Android was not pre-installed, linaro-alip 4.2.4 was installed (the version at this location: http://builds.96boards.org/snapshots/dragonboard410c/arrow/debian/23/)

As mentioned, other than a brief flash of the BT LED at power on, nothing happens with those two LEDs.

It seems they are assigned in the same manner as the other ‘user’ LEDs under Linaro and their trigger is set to ‘none’ (via /sys/class/leds/apq8016-sbc:yellow:wifi/trigger and …/apq8016-sbc:blue:bt/trigger) for each LED so no activity will occur on those two LEDs by default under Linaro in the release mentioned above, at least.

If you want one to show when packets are received on the network interface you can execute (as root or via sudo) ‘echo phy0rx > trigger’ from within the directory shown above for whichever LED you choose. Run a ping or whatever you like to generate some traffic and you’ll see the corresponding LED blink when packets are received. The trigger change does not persist across reboots and this is about as far as I went with it. I did not see a trigger listed that would activate an LED when there was activity on the BT radio and didn’t investigate that any further either. I mainly wanted to ensure the LEDs on my board worked and whether they should be doing anything by default.