Where is DragonBaord Android-M image?


#1

Hi,please tell me about Android 6.0 image.

Now,I look to here,
https://www.96boards.org/db410c-getting-started/Downloads/Android.md/

The release note in this page is written about DragonBoards Andoroid OS upgrading Android 6.0.
But,maybe,SD image in this page is until Android 5.0. Where is Android 6.0 image?
Or I should building cord Auroras file? Thank you!


#2

Hi Hasegawa-san,

Please refer to https://developer.qualcomm.com/qfile/28828/lm80-p0436-2_sw-build-and-install_gd_linux_android.pdf, especially Section 2 on Downloading the Software.

HTH


#3

Hi vchong,

Thank you for quick reply and good advice.

I tried to build in reference to this,but I failed it…
So if Android-M SD card image is distributed,I want use it.
OK,I try to build one more! Thank you!


#4

Ah sorry. If you don’t want/need to (re)build the images, then you can just use the prebuilt ones. The latest ones are here: http://builds.96boards.org/releases/dragonboard410c/qualcomm/android/16.06/


#5

Ok,but I think this image have a issue.
http://www.96boards.org/forums/topic/unfortunately-the-process-com-android-phone-has-stopped-dragonboard/#gsc.tab=0

I had installed Android-118 image,but I looked same issue.
This files last modified until 25-Jul 2016,So I think this issue is not fixed.Does not it?

Thank you!


#6

Yes, the bug is still being tracked here: https://bugs.96boards.org/show_bug.cgi?id=417, which does provide a workaround but requires a rebuild, and you’re having problems rebuilding. Let me see if I can try to get an update regarding the bug and report back later.


#7

@hase Please try this one and let us know if it works for you: http://builds.96boards.org/snapshots/dragonboard410c/qualcomm/android/128/

Thanks!


#8

@vchong Thank you! I find this image too.
(just time this is update!)

Now I try to it,please wait a just a moment…
Thank you!


#9

Hi @vchong ,

Could we download code for the latest release (android 128)?

Thanks.

Best regards,
Johnny


#10

I installed Android 128 image.That issue is fixed.thank you.
But This memory use 700MB…If someone have good idea of free up memory,please tell me about it.

By the way,will 96Boards update Android SD image of wabsite link?

Thank you!


#11

Hi @vchong
I installed build 128 from SDCard. It works, thank you for fixing this for us.

One little complaint, it keeps spitting out the following messages on the console so it is a little hard to use the console.

[ 2080.193881] init: Warning!  Service fuse_uicc0 needs a SELinux domain defined; please fix!
[ 2080.201667] init: Starting service 'fuse_uicc0'...
[ 2080.208149] init: Starting service 'ims_rtp_daemon'...
[ 2080.225838] init: Service 'fuse_uicc0' (pid 6981) exited with status 1
[ 2080.232036] init: Service 'fuse_uicc0' (pid 6981) killing any children in process group
[ 2080.240249] init: Service 'ims_rtp_daemon' (pid 6982) exited with status 1
[ 2080.246204] init: Service 'ims_rtp_daemon' (pid 6982) killing any children in process group
[ 2081.978589] [19:10:13.518250] [00000009504B4910] [wpa_s]  wlan: [E :HDD] wlan_hdd_get_frame_logs: Frame Logging not init!

Anything you can do about this?


#12

Hi @ljking
Please check my reply here: http://www.96boards.org/forums/topic/init-warning-service-fuse_uicc0-needs-a-selinux-domain-defined-please-fix/#post-19483


#13

@dodoamuro The source package is the same. Only the vendor package has been updated and can be found here:
https://developer.qualcomm.com/download/db410c/android_board_support_package_vla.br_.1.2.7-01010-8x16.0-4.zip

@hase 96Boards will update Android SD image link on website soon. Please check the site again in 2-3 days if you need it.

@ljking Actually QC fixed it themselves. I just pasted the link to the release. :s

@hzx1991 Thanks! The issue is now being tracked on https://bugs.96boards.org/show_bug.cgi?id=472. Please add yourself to the cc list to get notified on progress.


#14

Hi,

>96Boards will update Android SD image link on website soon. Please check the site again in 2-3 days if you need it.

I think that Android SD image is not updated in link.Why not?


#15

@hase Sorry for the delay. The request to update the page was sent ~16 days ago (https://github.com/96boards/documentation/pull/49/files) but the maintainer was a bit reluctant to do it due to https://bugs.96boards.org/show_bug.cgi?id=417 and https://bugs.96boards.org/show_bug.cgi?id=472 in the 16.06 release, so I’m waiting for a new release before asking again for the change to be merged. You already have the link to the 16.06 image, but do you need the links on the pages updated soon for any particular reason?