Webcam problem on Linaro


#1

Having problems with the webcam video feed. I’m a developer using OpenCV to computer vision tasks and I was unable to get video feeding from the webcam using a resolution above 320 x 240. I tried with VLC and GUView thinking it was something wrong with OpenCV video capture but the results are the same. I tried with different web cam and the same result. I’ll appreciate any help.


#2

Please try using the supported v4l2 API or Gstreamer. Is that an option for you?


#3

Hello,
I’m using v4l2 driver and Gstreamer to stream the video but even with Gstreamer I couldn’t get a video feed above 320 x 240. Also OpenCV uses v4l2 driver to capture the video feed. As I said before I really need this to computer vision tasks.
Thanks for the help.


#4

can you paste the output of dmesg after inserting the camera please?


#5

also, I suppose you have already gone through this thread?

https://www.96boards.org/forums/topic/issues-with-usb-webcam-support/


#6

Actually there was recent fix that improved the usb performance by factor of ten

[please read this post: https://www.96boards.org/forums/topic/issues-with-usb-webcam-support/#post-9074]

  • fix USB performance issue
  • fix a potential VIDC build issue (reported on the forum, and from QCOM internally)
  • remove some WLAN erroneous warning from the console
  • enable SPI master on the low speed expansion
  • merge 4.2.4 stable branch

I wonder if you have this fix in your baseline.

You could pick it up from either of these snapshots:

  1. ubuntu: http://builds.96boards.org/snapshots/dragonboard410c/linaro/ubuntu/107/

  2. debian: http://builds.96boards.org/snapshots/dragonboard410c/linaro/debian/14/

That will give you a steady 720p@15fps using MJPEG output (and VGA@30)


#7

Hello ldts-jro
I already have read this issues-with-usb-webcam-support. I’ll try the last build that fixes the USB drives and see how it performs I let you know.
Thanks for the help. I appreciate it.