Voltage problems


#1

I just received a 410c, and have noticed some very odd behavior with the 5V rail. I was attempting to power the board with 10V, and it seemed to power up fine, but would not power up any of my USB devices (mouse was dead, keyboard dead, no lights on either). On further inspection, I found the board was not putting out any power to the USB ports, regardless of the position of the USB Host switch. I started varying the input voltage to the board, and noticed that when I got down around 7V it started to put out about 4V on USB. At 6.5V it put out nearly 6V on USB, and I had to bring the input voltage all the way down to ~5.8V before it finally put 5V out on USB and I was able to use my keyboard/mouse.

It seems to be behaving just fine on 5.8V, but this is out of spec, so I’m not comfortable with it…however it appears to be necessary in order to use any USB devices because the 5V rail is so finicky.

Any thoughts?


#2

On further inspection, it looks as though the 5V rail is actually just way too high, and I guess there’s a protection chip that’s blocking power to the USB port when the voltage is above ~6? It looks like when the input voltage is 10V, the output of the 5V DC/DC converter is nearly 9V.

I’m wondering if there’s a mistake in one of the feedback resistors on the 5V DC/DC converter. Does anybody have any schematics of the board so I can compare what’s on mine? I could google the part number of the switcher and look up the feedback system as a last resort.


#3

You can find the schematics here:
https://www.96boards.org/products/ce/dragonboard410c/docs/


#4

Thanks - I went looking but missed it somehow…

Looks like it’s expecting .6V for the feedback. I am measuring .6V on the 3.7V reg feedback for all input voltages, but I’m only getting .6V on the 5V reg feedback when the input is 5.8V (which makes the output 5V). When the input (and therefore the output) voltage is higher, the feedback voltage is higher too, but the regulator isn’t reacting. So it looks like the feedback circuit is correct, but for some reason the regulator isn’t trimming the output when it’s too high. I’m guessing it’s a bum regulator…maybe a dead internal reference. Unfortunately it doesn’t look like a part I can get here easily in the states. I guess I’ll contact Arrow about an RMA.

In other news, the power/performance ratio of this processor is very nice! Exactly what I was hoping for.


#5

USB is not working when Dragonboard 410c is powered with more than 6VDC.

I’m having the same problem as suicidaleggroll. I am booting into Android, and I have found that if the input voltage is greater than 6VDC, The USB ports J2 and J3 do not power up. I tried 12V, 9V, and 7.5V, all of which did not work. After finding this post, I tried 6V, and that worked, so I am concerned there is something wrong with my board. Any suggestions?
My connections are:
Low Speed Connector J8 pin# 38 SYS_DCIN: +6VDC
Low Speed connector J8 pin# 40 SYS_DCIN: GND
HDMI connected to smart TV
USB J2 connected to wireless keyboard & mouse dongle
Boot Switches S6 are set to ‘0000’, all in off position.


#6

Do you have a multimeter? If so you can try measuring the 5v regulator’s output voltage as you vary the input voltage. It should be a constant 5v as long as the input is between 6.5-18v, but if you see it’s always about 1v below the input, then it’s probably a bad regulator like my board had.

It’s on the bottom of the board, the easiest place to grab the voltage is on the output of L14 IMO.

I got an RMA replacement from Arrow and the new board works as expected.


#7

I wonder if this is why my USB ports aren’t working. I recently made a post concerning a blockage I encountered when attempting a workaround after experiencing the symptoms described in this thread(https://www.96boards.org/forums/topic/installing-debian-image-over-ftdi-connection/). Looks like I’ll try for an RMA from Arrow tomorrow.


#8

I just confirmed that at 6VDC input the voltage at L14 output is 5.2VDC, and at 7.5VDC input, the voltage at L14 output is about 30mVDC. It looks like an RMA is in order.


#9

So when I RMA’d my board, Arrow just sent me a new one and didn’t ask for the old one back. After confirming the new one worked, I ordered a replacement SY8104ADC from Aliexpress. Two months later it finally arrived, I swapped it out, and now the original board is working perfectly as well.

I had to order a batch of 5 ICs, so I still have four left. If anybody in the US who has a faulty 5V reg wants one, just let me know. If you’re not comfortable with SMD soldering, I don’t mind swapping it out here if you just send me your board and pay for return shipping.

Just throwing that out there if anyone is interested.