/usr/bin/ld: cannot find -lupm-i2clcd solve this please

mezzanine
tutorial
96boards

#1

its not working downloaded latest stable release and still i face this issue, 7 days are gone


#2

UPM libraries have been updated to v1.6.0 upstream release. Due to this update -lupm-i2clcd has been renamed to -lupm-lcd. So refer to upstream repo [1] for any other changes that may be required in sensor mezzanine example you are trying to run.

BTW, there is already a documentation bug logged here [2].

[1] https://github.com/intel-iot-devkit/upm/tree/v1.6.0
[2] https://github.com/96boards/documentation/issues/573


Problem getting Grove Starer Kit to Work
#3

well i just tried old Debian version 17.09 and its working fine, why buster have many issues , i think buster version 18.09 not stable versions… i found lots of bugs in it. either you are saying functions are deprecated or changed.