USB ports stopped working


#1

It happened to me on my 3-rd card.
Suddenly after several days of working with USB ports, that includes connecting and disconnecting of devices, USB ports stopped detecting devices connection.
I do not see any new device under /dev/ upon connection any more.
The devices are working on same format on XU4 card without any problems, including connect and disconnect many times a day.
It looks like hardware problem, probably the card’s USB hub hw is not protected enough.


#2

Which OS are you running ? Debian ?
Do you still have 5V on USB VBUS pin (1) ?
Is there any message in dmesg on device connection?


#3

Hi @Loic,

I’m running Debian build 215.
No 5V on USB terminals. Both USB seems dead.
No error message on USB connection in dmesg.


#4

From the schematics, there are per-port over-current protection thanks to NX5P1100UK chips. These chips are designed to isolate a VBUS voltage source from a VBUS interface pin automatically when a fault condition occurs. It would be weird that both of them are damaged. VREG_5V is used as input for these circuits, so maybe the problem is here. Could you check VREG_5V (+5V) on your board (available on Low speed connector, pin 37).


#5

5V exists on this pin.
Some hardware between USB connector and the VREG_5V on low speed connector ?


#6

The circuit schematics are here:
https://developer.qualcomm.com/download/db820c/dragonboard-820c-schematics.pdf


#7

I had a similar issue here, with a brand new DB820c (it worked fine for a couple of hours). The USB 3.0 Hub Controller IC is overheating and no USB port is working anymore. It’s a hardware defect, in my case. It’s sad.


#8

Do you refer to the VLI (VL812) on the bottom side ?
@ndec, any known issue on your side?


#9

This is exactly what i have on my second card.
Same issue.


#10

Yes, exactly. This IC (VL812) is getting very hot as soon as the DB820c is powered on, and the USB ports no longer work.


#11

I remember reading a post somewhere, I think by ndec, that you should not switch S1 with any USB devices plugged in. Presumably powered ones. I will try to find the post.
It was in the installation documents, not a post: https://www.96boards.org/documentation/consumer/dragonboard820c/installation/board-recovery.md.html#using-usb-flashing-tools

Warning: putting the device into EDL mode while the device is powered or when USB is plugged can cause damage to the board, the actual root cause is under investigation, and a hardware fix will be implemented in newer board revision.


#12

That could be the point indeed. btw, @cezmen, @salex, what is your Board hw revision?


#13

Hello, Loic.

I’m reading “MP25-P2214-2 REV A” , “25-P2214-P1 REV A” and “PWB, MAIN, P4, DB820C, SBC, APQ8096”. I’m not sure which of them means the hardware revision.

Thanks.


#14

I do not have the problem described in this thread (yet :worried:), but I have always taken that warning seriously. But, just for comparison, this is what I have found on my board:

  Stickers
    Job# 4941523-H100 
    Rev: D
    COO: US
    N10N3DNRT
  Silk Screen
    PWB, MAIN, P4, DB820C, SBC, APQ8096
    MP25-P2214-2 REV A
    25-P2214-P1 REV A
    OPC E-08 94VO
    RL.36 16(03)
    MADE IN CHINA

#15

In my specific case, the DB820c worked for a while (a couple of hours) and suddenly its USB ports stopped working in normal use (not EDL mode). While investigating the issue, I noticed that the VL812 IC was overheating abnormally.


#16

I do not think its is specifically EDL mode that causes the problem but any change of S1. For instance, did you try booting from an SD card?


#17

No, I didn’t. I’ve used the fastboot method for flashing the DB820c.
The issues occurred much later. I do use USB devices such as USB wireless keyboard dongle and USB flash drive (thumb drive).

Anyway, If the DB820c is so sensitive to the S1 switch positions, I believe this should be fixed in the hardware design. User interface should never harm a product, I my opinion.


#18

In my case:
Stickers
Job# 4941523-H100 **
** Rev: D

** COO: US**

Silk Screen:
PWB, MAIN, P4, DB820C, SBC, APQ8096
MP25-P2214-2 REV A
25-P2214 - P1 REV A