USB performance issue


#1

Hi,

I’m running Linaro’s Ubuntu 15.07 build and finding that no matter what USB 2.0/3.0 device I plug into my Dragonboard 410c I can’t seem to be able to transfer more than about 2.2MiB/sec to/from it. This includes ethernet, hard disks, etc…

Is there any known issue stopping the board from running USB devices at high speed? I’m struggling to find anything about this apart from unresolved issues with data transfer rates for webcams.


#2

LinuxJedi, I have been curious on this issue too. Could you let me me know how you measured those
transfer rates?


#3

Sure, using a USB hard drive I ran “hdparm -t” and using a USB ethernet I ran the commandline speedtest (https://github.com/sivel/speedtest-cli) and scp from a local machine to the DragonBoard. All gave very similar results.

Unless I can figure out a way of getting at least 100Mbit out of the USB (and/or someone fixes the multicast WiFi issue) I can’t use the board for the purpose I bought it for.


#4

hi, we are looking into that , will get back to you here quickly.
thanks!


#5

i think this is fixed, please see

https://www.96boards.org/forums/topic/super-slow-usb/#post-9071