USB Camera on Android - 410C


#1

Just received our dragonboard 410C. It came with pre-built android. I tried connecting a usb camera to it. The camera is a regular USB Camera module - USBFHD01M. Also tried a Logitech USB Camera. First thing. There was no Camera Application in the image that came loaded on the board. Installed “Open Camera” – a standard camera application. Had to install this application from SD Card. Since there was no Play Store App on the board. The Cameras remained undetected.

Next, I downloaded the Android Image - “dragonboard410c_sdcard_install_android-40-66.zip” from 96Boards - Downloads Page. I flashed this image. Here’s the interesting thing. After I booted the board (after flashing), I could see a “Snapdragon Camera App”. However, it vanished as soon as I clicked on the app.

My subsequent attempts with my USB Cameras yielded no result. The camera module remains undetected.

Would appreciate any pointers that will enable me work with a USB Camera.


#2

There was some discussion of this in a separate post: https://www.96boards.org/forums/topic/camera-compatibility/#post-7510
"USB cameras will work on the DragonBoard 410c and the Logitech 720p webcam has been tested on Android. The default android application from playstore worked fine for this."
There is an application note on enabling this on the Qualcomm Developer Network here: https://developer.qualcomm.com/download/db410c/usb-camera-application-note.pdf


#3

Hi

I have the same problem with you,do you solve it?


#4

hi,

Even i have the same problem if ayone have resolved the issues please share the solution.

thanks in advance.