Upgrade to 4.8 Kernel


#1

Hello,

I’ve installed debian using 96boards & linaro’s distribution (http://builds.96boards.org/releases/dragonboard410c/linaro/debian/latest/) and it worked properly.

The thing is, I want to use 4.8 linux kernel, while that distribution has 4.4 only. What’s the most convinient way of upgrading the kernel?

What I tried and failed -
I built kernel 4.8 mainline using the same config file of linaro’s latest build (using arm64 cross compiler), and created an image from that, using that command:
./skales/mkbootimg --kernel arch/arm64/boot/Image
–ramdisk initrd.img-4.4.23-linaro-lt-qcom
–output boot-db410c.img
–dt dt.img
–pagesize 2048
–base 0x80000000
–cmdline “root=/dev/disk/by-partlabel/rootfs rw rootwait console=ttyMSM0,115200n8”

Then, I’ve used fastboot in the following manner:
sudo fastboot flash boot boot-db410c.img

I’ve thought I should probably also supply a rootfs like in the original debian installation, so I’ve also used
sudo fastboot flash rootfs linaro-jessie-alip-qcom-snapdragon-arm64-20161006-144.img (linaro’s build)

I’ve connected the board to the screen, and boot never happened.

Can you help me troubleshoot the problem?

Thanks!


#2

Hi,

Do you have a serial connection to the board to check the logs while booting up? Mainline kernel might boot but maybe not enough to have certain components working like display/gpu/etc.


#3

What to you mean by serial connection? for the whole process, I’m connected via USB. Do I have any way troubleshooting boot process through USB?

Are the steps look alright? Is it possible to use mainline 4.8 kernel with 410c?


#4

Yes, the steps look alright, but as mentioned earlier the graphics components might not work, which was why I asked about the serial connection. The USB connection is for fastboot. The serial connection allows you to see the boot logs as the board comes up to check for errors. To setup the serial connection, see https://github.com/96boards/documentation/wiki/dragonboard-410c-installation-guide-for-linux-and-android#setting-up-the-uart-console. In place of TTL-232RG-VREG1V8-WE, you can use below more economical alternatives:

  1. http://usb2serialcables.com
  2. http://www.96boards.org/products/mezzanine/uarts + regular USB-microUSB cable.

#5

Per http://www.96boards.org/forums/topic/booting-linux-from-sd-card-issues/#post-18416:

“the mainline/upstream kernel is unlikely to give you good results. While we are working to get as many patches merged as possible, this is still not finished. So you should really be using either our LT released kernel, or you need to be prepare to (heavily) patch your own kernel.”