Unable to connect to wifi on the hikey960 board with debian image on it


#1

I have a debian image running on my board.

root@hikey960:/home/shunya# uname -r
4.14.0-rc7-linaro-hikey960
root@hikey960:/home/shunya# uname -a
Linux hikey960 4.14.0-rc7-linaro-hikey960 #1 SMP PREEMPT Wed Mar 14 17:54:05 IST 2018 aarch64 GNU/Linux

My wifi works fine when I first connected, but when I changed it and tried to connect at a different place, I do not get my list of available wifi networks.

root@hikey960:/home/shunya# ifconfig
lo: flags=73<UP,LOOPBACK,RUNNING> mtu 65536
inet 127.0.0.1 netmask 255.0.0.0
inet6 ::1 prefixlen 128 scopeid 0x10
loop txqueuelen 1000 (Local Loopback)
RX packets 2094 bytes 169358 (165.3 KiB)
RX errors 0 dropped 0 overruns 0 frame 0
TX packets 2094 bytes 169358 (165.3 KiB)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

wlan0: flags=4099<UP,BROADCAST,MULTICAST> mtu 1500
ether 6a:b5:3d:9d:f4:f2 txqueuelen 1000 (Ethernet)
RX packets 0 bytes 0 (0.0 B)
RX errors 0 dropped 0 overruns 0 frame 0
TX packets 0 bytes 0 (0.0 B)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

root@hikey960:/home/shunya# nmcli device status
DEVICE TYPE STATE CONNECTION
wlan0 wifi unavailable –
lo loopback unmanaged –
root@hikey960:/home/shunya#

It worked once and I was able to do installations, but it does not work later at a different place/

Can anyone help in proceeding with this issue.


#2

It does connect, but i cannot use the HiKey960 for running my lightning node (with 200+ active connections). Too much drops. Messages like “Beacon loss detected. roles:0x1”. Running a lightning node on the HiKey960 was the main reason for my purchase :disappointed:
I had a Raspberry Pi 3 Model B+, which ran fine but i ran into memory problems when my node became bigger. My lightning node requires after restart lightning daemon for a backup) over 3.6 GB base memory. Of course I use the latest Debian image. Maybe the problem can be solved by trying different WiFi settings, but i am no expert on that and there is very little info on that topic to fine tune a WiFi connection. Maybe someone has anything to share about it. For now, i must use my desktop pc again for running the node. Must be online 24/7.


#3

It succeeded me running my lightning node on the HiKey960. I had to place the device closer to my router. I also had to disable writing kernel messages to the serial port. Some SysRq messages shut downed the device. All I had to do was echo 0 > /proc/sys/kernel/sysrq.

So finally a happy Hikey960 user! :smile::sunglasses:


#4

@MichaelG Awesome! Glad to hear that HiKey960 is being used as a Lightning node. Please feel free to post your experience as a blog on 96Boards site if you like.


#5

Thank you. Currently i’m very occupied with lots of other stuff. Will post my experience when i got some spare time. For anyone who cannot wait to start running an lightning node on the HiKey960 I have the following tip:
Please follow this post. It was written for the Raspberry Pi.
Well I dare to say that the HiKey960 has blown away all expectations compared to the Raspberry Pi. In all facets. Memory, speed, size in EVERYTHING it blown away in compare to an Raspberry Pi 3 Model B+ :sunglasses:. When your lightning grows in size you have to switch to another device with more base memory.
Unfortunately i’m too busy to write my experience right away. Good luck