Unable to boot linux on HiKey 960


#1

Hi,

I am unable to flash linux on a new HiKey 960 board based on the steps here:

I tried using fastboot as well as SD card as mentioned here:

The boot image and fastboot files were downloaded from here:

The version of boot image is boot-linaro-stretch-developer-hikey-20180828-19.img

Some observations are here:

  1. Upon flashing first, the board failed to boot without any led lights being turned on.
  2. On second attempt, the lights were on, but the USB-A and HDMI ports were non functioning as there was no power output.
  3. I also tried recovery flash of the base firmware in vain and it did not yield any result.

I repeated the experiment with another new HiKey 960 board only to observe the same result.

Is there a version of the Debian image that is stable and that which drives display?

How could I ssh to the board if the board does not drive the HDMI port?

Any help would be appreciated.

Hari


#2

Current Debian kernel doesn’t have support for USB and HDMI drivers. One way is to update kernel with 96boards kernel.

You could use debug uart to enable wifi network from command line using following link. Then you could do ssh to board.