Ultra96 V2: bad wifi connection


when we use default factory image in ultra96 v2 board, wifi has the following problems after connecting to wireless ap (2.4G):

  1. The packet loss rate is about 30%;
  2. The transmission data rate is low, 20kB/s-50kB/s;
  3. Direct Wifi connection between board and phone cannot be established for most of times;

what we have tried:

  1. Take a dedicated ap, issue still exists while other devices work well;
  2. Verified 3 boards, found the same problem.

Thanks a lot for any help!

Any idea on this? I haven’t yet put my unit through the paces, I’ll test and see if the issue shows up on my end.


Any update? could the issue be reproduced on your side?

I believe there may be an issue with the default factory OS image for the Ultra96-V2 board. I believe the access point for the WiFi config may not work correctly, and that this issue was fixed in the released PetaLinux BSP (for PetaLinux v2018.3) that is online here:

OS binaries (boot.bin, image.ub, and rootfs.tar.gz) are included in the BSP archive.

You can find instructions for installing the BSP in Xilinx UG1144:

Please try booting these OS binaries, configure the WiFi via the access point ( to connect the Ultra96-V2 board to your WLAN, and report the iperf3 throughput results here.


Hi @narrucmot

I have tried the BSP you provided above(for PetaLinux v2018.3) and rebuilt the image.
But I found that it seems to be little difference with the OS image, and the wifi performance is still not good.

Later I’ll provide the iperf3 throughput results if necessary.

Best Regards,

Yes, please share iperf3 test results. Please also test iperf3 using a public iperf3 server. For example:
# iperf3 -c ping.online.net -i 5 -t 30 -p <5200-5209>

A list of free public iperf3 servers around the world can be found here: