U-Boot Panic DDR addr bus test: can't access memory @ 0xc0000004

I had my avenger96 sitting on my desk for a few weeks, no if I try to boot it, I am getting the following (pre?) u-boot panic:

NOTICE:  CPU: STM32MP157AAC Rev.B
NOTICE:  Model: Arrow Electronics STM32MP157A Avenger96 board
INFO:    Reset reason (0x15):
INFO:      Power-on Reset (rst_por)
INFO:    Using SDMMC
INFO:      Instance 1
INFO:    Boot used partition fsbl1
INFO:    Product_below_2v5=1: HSLVEN update is
INFO:      destructive, no update as VDD>2.7V
NOTICE:  BL2: v2.0(debug):
NOTICE:  BL2: Built : 13:13:37, Oct  2 2018
INFO:    BL2: Doing platform setup
INFO:    PMIC version = 0x10
INFO:    RAM: DDR3-1066/888 bin G 2x4Gb 533MHz v1.41
ERROR:   DDR addr bus test: can't access memory @ 0xc0000004
PANIC at PC : 0x2ffdf9d9

Exception mode=0x00000016 at: 0x2ffda000

Since nothing on the firmware side changed, I worry this is hardware. I need help in understanding what actually failed. I am guessing Memory failure perhaps?
I am using this sdcard image: https://releases.linaro.org/96boards/avenger96/19.10/
I have tried multiple sdcards so its not that.
I tried with a known good upstream uboot build that i had flashed on the av96’s spi flash, that has stopped responding as well, nothing on the uart at all.

Hello,

I encountered the same problem (but with a different board), have you found a solution to your problem?

Best regards,
Charles

not really. I think that board just died due to damaged memory chip

Thank you for your answer. It happened that the RAM chip wasn’t soldered properly on the PCB. Heat it up again and everything works again.

Best regards,
Charles