The problem for UART0 on Dragonboard 410, Android 5.1.1


#1

Hi, everybody!

I want to communicate Dragonboard 410c with Arduino.

Because UART1 is used for console on Dragonboard 410c, so I’m using UART0.

I’m now using “dragonboard410c_sdcard_install_android-99” Android 5.1.1 image on Dragonboard 410c.
Also, Because Dragonboard Low speed pins is using 1.8V, I’m using TBX0108 level converter.

I success to send data from Dragonboard to Arduino, but I failed to receive data on Dragonboard.

Help me!!!.
Is there any way?

Thank you!


#2

Hello Wang, This is true, this is a problem and I wrote a thread on this. Pls refer to this thread http://www.96boards.org/forums/topic/uart0-android-sensors-mezzanine/#post-17730

I probably found a simple solution.
jean-marc


#3

Follow UP
OK I found the simplest way to get rid of this problem. I removed the resistor R5 (620 ohm) to open the RTS signal and I can communicate with the DragonBoard.
In such way RTS does not reset the Arduino anymore.
Another problem shows up, the data are plenty of garbage other than the message itself. I have no clue about this new problem.
I checked the signal hi and low level on the level shifter and it seems correct.


#4

Hello. jean-marc

Thank you for your replying.

Sorry, I don’t understand your idea.

I want to only communicate Dragonboard with Ardunino via RS232(Serial).
I’m not use RTS, CTS signal. I’m not to program to Arduino.

Is there a way?


#5

Hi. jean-marku

Also I do not find R5(620 ohm) on Dragonboard.


#6

Sorry Wang, I was answering the wrong thread.
I am using the Mezzanine Sensors Board and the R5 is on the Mezzanine board. RTS is set and reset the Arduino on the Sensors Board.
If you are not using the Sensor Board and use an external Arduino this is probably the same problem I encounter now. I receive the data but with a lot of garbage with my message. Also sometimes the communication locks and cannot see anything.
My Arduino sends data to the DragonBoard every seconds and I can see the string of data on the oscilloscope, but the data read to the DragonBoard comes with more garbage data as just the string of data and sometimes locks. :frowning:


#7

Hi @jean-marc

I have been using the sensors mezzanine board with no issues when receiving serial communication. Sample code for the Arduino, and for the DragonBoard 410c are HERE. No need to remove the resistor, no garbage characters.

Make sure you have the serial baud rates set correctly at both ends. You can also look at David Mandala’s blog HERE.

I attempted to demo this code during open hours and it failed to install. I went back and retried it this week with the latest Debian release and it worked fine.

Full Disclosure: I am an employee of Qualcomm Canada, any opinions I might have expressed may not reflect the opinions of my employer.


#8

Thanks for the help Ljking.
I do not understand very well your message and for sure I miss some point and understanding.
So I appreciate your help.

  1. Why should I load the Arduino code? I made one already and it is working fine. Sending data at 9600 bauds every seconds. Using an external FTDI driver this works fine. I can receive my data into a PC. But if I send the same data to the DragonBoard it is not working.

  2. What code should I use for the DragonBoard? You are using Debian I am using Android. Also David is using Debian.
    I already made an Android app to get the data and I also try by placing ttyHS0 with adb in “cat -v < ttyHS0” to get the data and I receive the same result on both (app and cat), receive my message + garbage.

  3. I have to remove R5 because when I place the ttyHS0 in receive mode this raise RTS and reset my Arduino. The Arduino stays in reset.

  4. I receive the data now that I remove R5 but I also get a lots of garbage. If I had the wrong baud rate I would receive only garbage.

  5. About demo? The Debian demo, there is nothing in Android. Every one refer to Debian so far.
    And at the end I am (we are) just simply trying to send data from a simple Arduino to the DragonBoard that it. And so far to me this is not working.
    Maybe my board is defective?

Any other idea? And thank you for a reply.


#9

Hello @Wang.
I do not know if you succeed in using UART0 with Android. If yes please let us know.

Here is the following on the other thread http://www.96boards.org/forums/topic/uart0-android-sensors-mezzanine/#post-17730