Tee-supplicant does not load


#1

I follow the directions on github and then loaded the kernel drivers. Next, I tried to run

tee-supplicant &
and got the error message below.
armv7sec armv7sec.0: shm service not available: FFFFFFFF misc opteearmtz00: tee_get: opteearmtz00::start() failed, err=-22

Then tee-supplicant exits. If try to run tee-supplicant again I get the following error.

misc opteearmtz00: tee_get: opteearmtz00::start() failed, err=-22 armv7sec armv7sec.0: tee_supp_open: ERROR Only one Supplicant is allowed

Which would imply the tee-supplicant is still running. But all of my xtest fail. Did I miss something in the directions?

-Machon


#2

I get this same error. Has anything been found?


#3

I am still trying to determine the cause. If you figure it out let me know.


#4

same issue here.

It looks like in the OP-TEE linux driver:
https://github.com/OP-TEE/optee_linuxdriver/blob/master/armtz/tee_tz_drv.c

in function: configure_shm() that configures shared memory for teeTZ, tee_smc_call() did not work.

I don’t know how to fix this.


#5

I just opened an issue with optee. Maybe someone there will know.


#6

The instructions at https://github.com/96boards/documentation/wiki/HiKeyOPTEE have been updated. Please try again from scratch. The main issue was that as of 24-Nov-2015, OP-TEE has been integrated into 96boards HiKey releases and snapshots images, so if you followed the previous instructions, you’re basically making an extra copy of the driver, supplicant and client library in the rootfs and confusing the system. The instructions have been updated to copy the files to the proper path to replace existing ones.