Sysroot


#1

Greetings.
just started with the board today and was hoping to port a few c-based libraries over.
I downloaded the linaro compiler toolchain but can not see a sysroot.

Q1: Is there one for download somewhere?

Q2: I tried to loopback mount the SD card image db410c_sd_install_debian.img but that didn’t work.

sudo mount -o loop db410c_sd_install_debian.img /home/DB410c/sysroot
NTFS signature is missing.
Failed to mount ‘/dev/loop0’: Invalid argument
The device ‘/dev/loop0’ doesn’t seem to have a valid NTFS.
Maybe the wrong device is used? Or the whole disk instead of a
partition (e.g. /dev/sda, not /dev/sda1)? Or the other way around?

I am guessing there is an offset but fdisk was unable to tell me anything about this strange image either.

file -s db410c_sd_install_debian.img
db410c_sd_install_debian.img: x86 boot sector

Q3: The board I received seems somehow dead to me. No LEDs come on when I plug it in, it doesn’t boot at all. I tried multiple power supplies, jumper settings, held down various buttons but nothing ever happens.
Is this thing bricked? I am booting from SD card from the image received.

Any help is much appreciated.

Roland


#2

Hi Roland,

Q1: Where did you download the toolchain? The sysroot should be in the same location. E.g.:
http://releases.linaro.org/components/toolchain/binaries/5.3-2016.02/aarch64-linux-gnu/gcc-linaro-5.3-2016.02-x86_64_aarch64-linux-gnu.tar.xz
http://releases.linaro.org/components/toolchain/binaries/5.3-2016.02/aarch64-linux-gnu/sysroot-linaro-glibc-gcc5.3-2016.02-aarch64-linux-gnu.tar.xz

The sysroot is also part of the binary under <extracted tarball>/aarch64-linux-gnu/libc/.