Suggested android app is not working


#1

From the official document “Enable USB Camera Application Note”, I tried to use UsbWebCam APK(serenegiant).
It was successfully installed to board. But I couldn’t open the app. Precisely, it open just for a moment and close soon.
I know some app don’t work on 410c. Actually, I tried another app, both working app and not working app existed.

But official doc say this app work. So, something was wrong in my case.
please tell me the hint to use this app.

my build is the same as the doc.
Android 5.1 (Lollipop)
Linux Kernel 3.10
Release: 15.06


#2

Works fine on my board.
Where did you get your UsbWebCam APK from?
Mine says UsbWebCamera_2.3.0.apk and was extracted from an install on my phone.
Do you have access to a serial console?
Any details or error messages on the console or monitor when the app closes?
Have you tried a different camera?
Also see https://www.96boards.org/forums/topic/usb-camera-on-android-410c/ for some previous discussions regarding usb camera.


#3

Thank you for your reply.

I got UsbWebCamera_2.3.0.apk from an install on my phone by using App Extraction(Android app).
This is logcat’s log that may be related.

///Start///
W/PackageManager( 730): Unknown permission com.android.vending.CHECK_LICENSE in package com.serenegiant.usbwebcamera

I/ActivityManager( 730): START u0 {act=android.hardware.usb.action.USB_DEVICE_ATTACHED flg=0x10000000 cmp=com.serenegiant.usbwebcamera/.MainActivity (has extras)} from uid 1000 on display 0

V/WindowManager( 730): addAppToken: AppWindowToken{11d5e34b token=Token{18b32c1a ActivityRecord{3f6deac5 u0 com.serenegiant.usbwebcamera/.MainActivity t166}}} to stack=1 task=166 at 0
I/ActivityManager( 730): Start proc 907:com.serenegiant.usbwebcamera/u0a36 for activity com.serenegiant.usbwebcamera/.MainActivity
V/FingerprintService( 730): startListening(android.service.fingerprint.IFingerprintServiceReceiver$Stub$Proxy@91d050f)
--------- beginning of crash
E/AndroidRuntime( 907): FATAL EXCEPTION: main
E/AndroidRuntime( 907): Process: com.serenegiant.usbwebcamera, PID: 907
E/AndroidRuntime( 907): java.lang.UnsatisfiedLinkError: dalvik.system.PathClassLoader[DexPathList[[zip file “/system/app/UsbWebCamera2.3.0.apk”],nativeLibraryDirectories=[/vendor/lib64, /system/lib64]]] couldn’t find "libc++_shared.so"
E/AndroidRuntime( 907): at java.lang.Runtime.loadLibrary(Runtime.java:366)
E/AndroidRuntime( 907): at java.lang.System.loadLibrary(System.java:988)
E/AndroidRuntime( 907): at com.serenegiant.utils.AA.<clinit>(AA.java:13)
E/AndroidRuntime( 907): at com.serenegiant.cameracommon.LVLBaseApplication.onMainActivityCreated(LVLBaseApplication.java:45)
E/AndroidRuntime( 907): at com.serenegiant.cameracommon.BaseApplication$1.onActivityCreated(BaseApplication.java:83)
E/AndroidRuntime( 907): at android.app.Application.dispatchActivityCreated(Application.java:189)
E/AndroidRuntime( 907): at android.app.Activity.onCreate(Activity.java:946)
E/AndroidRuntime( 907): at com.serenegiant.cameracommon.CameraActivity.onCreate(CameraActivity.java:17)
E/AndroidRuntime( 907): at com.serenegiant.usbwebcamera.MainActivity.onCreate(MainActivity.java:57)
E/AndroidRuntime( 907): at android.app.Activity.performCreate(Activity.java:6033)
E/AndroidRuntime( 907): at android.app.Instrumentation.callActivityOnCreate(Instrumentation.java:1106)
E/AndroidRuntime( 907): at android.app.ActivityThread.performLaunchActivity(ActivityThread.java:2278)
E/AndroidRuntime( 907): at android.app.ActivityThread.handleLaunchActivity(ActivityThread.java:2387)
E/AndroidRuntime( 907): at android.app.ActivityThread.access$800(ActivityThread.java:151)
E/AndroidRuntime( 907): at android.app.ActivityThread$H.handleMessage(ActivityThread.java:1303)
E/AndroidRuntime( 907): at android.os.Handler.dispatchMessage(Handler.java:102)
E/AndroidRuntime( 907): at android.os.Looper.loop(Looper.java:135)
E/AndroidRuntime( 907): at android.app.ActivityThread.main(ActivityThread.java:5254)
E/AndroidRuntime( 907): at java.lang.reflect.Method.invoke(Native Method)
E/AndroidRuntime( 907): at java.lang.reflect.Method.invoke(Method.java:372)
E/AndroidRuntime( 907): at com.android.internal.os.ZygoteInit$MethodAndArgsCaller.run(ZygoteInit.java:902)
E/AndroidRuntime( 907): at com.android.internal.os.ZygoteInit.main(ZygoteInit.java:697)
W/ActivityManager( 730): Force finishing activity 1 com.serenegiant.usbwebcamera/.MainActivity
W/KeyguardServiceDelegate( 730): onScreenTurnedOn(): no keyguard service!
I/ActivityManager( 730): Start proc 941:com.android.settings/1000 for broadcast com.android.settings/.DiagPortBroadcastReceiver
I/ActivityManager( 730): Process com.serenegiant.usbwebcamera (pid 907) has died

///End///


#4

Are you running the latest Android build? Or still the one that the board shipped with?

You can tell by looking at the launcher’s application drawer; if the background is BLACK, it is the old build. If the background is WHITE, it is the new build. If you are running old build, I suggest updating and trying again.