Sudo apt-get update/upgrade not working


#1

Hi! Im trying to install OpenCV and Tensorflow on Dragonboard 410c but I came across some problems.

I installed Debian and the Mezzanine camera following this tutorial..

When I run sudo apt-get update, the command fails on 151.101.112.204 port 80. The same thing happens when I run sudo apt-get upgrade.

UPDATE: When I tried running sudo apt-get install git, it still did not work. It was stuck on

Get:1 http://security.debian.org stretch/updates/main arm64 git arm54 1:2.11.0-3+deb9u3 [3775 kB]]

If anyone has any pointers to solutions, I would greatly appreciate it.


#2

That looks like a networking problem. How are you connected to the network? Do basic commands like ping debian.org work?


#3

Hi Daniel! Thanks for your reply. It is not a networking problem as I have already tried commands like ping and they worked just fine. If you have any other suggestions, I would be more than happy to try them out.


#4

@beerjamin Yesterday, I also faced similar issue with “sudo apt-get update”. Maybe it could be server issue. But now its resolved and working at my end. Please try again.


#5

I just tried it again. Still the same result. The query takes too long to process and after some time this error occurs: Err:13 http://obs.linaro.org/linaro-overlay-stretch/Debian_9.0 ./ Sources
404 Not found.
I already checked out the directory and it exists.


#6

@beerjamin So you are able to access http://obs.linaro.org/linaro-overlay-stretch/Debian_9.0/Sources from host machine? If yes, then try to check board network connectivity. Also you could try “wget http://obs.linaro.org/linaro-overlay-stretch/Debian_9.0/Sources” on board and see if it works. TBH, I don’t see any other reason for the error you have provided.


#7

@sumit.garg So I just ran wget http://obs.linaro.org/linaro-overlay-stretch/Debian_9.0/Sources as you advised. First I ran it on my host machine and the HTTP request was sent and a response was received.
However, when I ran the same query on the board, the HTTP request was sent but an answer was never received.
Do you have any ideas on how to solve this?


#8

@beerjamin It seems to be board network connectivity issue. How is your board connected to the network?


#9

@sumit.garg I have established a wireless connection.


#10

@beerjamin Please check if “ping obs.linaro.org”. If it doesn’t then you could try to reconfigure your wireless connection. I do use https://www.96boards.org/documentation/consumer/guides/wifi_commandline.md.html guide to enable Wifi on my dragonboard 410c.


#11

@sumit.garg I can ping obs.linaro.org. I already reconfigured my wireless connection according to the manual and it still does not work. Even when I try to open pages in the Chromium Browser the connection fails.
I am not sure why the configuration from the manual would not work.


#12

@Loic Can you please have a look at wifi issue @beerjamin is facing? It seems he is using Debian 17.04 release.


#13

This is an old image… Are you connected on a personnel AP/Router or in a larger infrastructure ? Once connected to the AP could you check default gateway is correctly configured with route command (it seems to be ok though). Could you also try to flush all iptables rules with ‘sudo iptables -F’.

I would suggest you to upgrade to a newer Linaro release, this request however kernel rebuild to enable D3 mezzanine.