Starting with Android O


#1

My intent with the HiKey is to install Linux on it. However, I’ve had extremely little experience with Android, and the version of Android O doesn’t seem to come with Google Apps. As a result, I must admit that I’m struggling to work out how to get started installing software. Does anyone have a resource to help get started?


#2

install adb and fastboot on ubuntu and then its as simple as connecting to usb c and
sudo abd usb
sudo adb install <.apk file name>


#3

That worked a treat. I’m far more familiar with regular Linux.

Does anyone have a list of the apks that work with Android O? I’ve been using apkmirror.com, and a few things work (e.g. Plex Media Server), although sometimes glitchily (e.g. playback from Plex). I note that adding an account to Settings makes it crash each time, I presume something that is unlikely to be fixed until the Google Play store better supports Android O? Also, is there a standard method for rooting? I was thinking of testing Linux Deploy.


#4

I gave opengapps a shot but it always crashes, so we may have to wait till the official android o release for proper working gapps


#5

Perhaps creating a list of confirmed “works” software might be useful to people? Something like:

Plex - Works, but playback from surround sound to stereo picks wrong channels
Plex Media Server - Works


#6

@ric96 If you have any luck with the leanback libraries and launcher, please let me know. I’m helping test some software on the Shield, and it would be useful to get it running on the HiKey 960 too.


#7

i got the launcher to work, but not from opengapps… I got it to work using nexus player binaries provided by google
https://github.com/96boards/website/blob/master/96boards.org/Projects/AOSPTVHikey/README.md


#8

It looks like things are getting moving for Android O:

http://www.cnx-software.com/2017/05/18/google-releases-android-o-developer-preview-2-announces-android-go-for-low-end-devices-tensorflow-lite/


#9

@ric96 Hold on. Isn’t Nexus Player atom-based? It’s surprising that the binaries are portable.
The AOSPTV link is dead by the way, and if I google for “AOSP TV For Hikey Boards” this post is the only thing I find.


#10

https://github.com/96boards/website/blob/master/96boards.org/Projects/Archive/AOSPTVHikey/README.md


#11

@ric96 Thanks! Any idea if mediacodec hardware encoding is in there yet? I’m involved in a project using ffmpeg for TV transcoding, and now that leanback is working fully I think I should be able to test it out.


#12

@ric96 Using your Android TV build. I’m having trouble getting external hard drives read. I’ve tried two drives, both single partition with exfat on GUID and MBR partition maps, with no luck. So I switched to an SD Card and that worked fine. However, so far one of my apps, which I know works fine on the Shield, can’t write to it. Is something odd going on, or is it just my inexperience with Android?

Also of note is that I had to use a powered USB hub for the spinning (2.5") drive for it even to spin up, but I suspect that’s a hardware issue.


#13

Usb storage isn’t working


#14

Ugh. That’s frustrating. The software I’m testing also seems to be struggling with SD card storage too, but I suspect that’s their code’s issue, which assumed it works like the NVidia Shield, not a build one.


#15

The software in question is Channels DVR by the way:

It runs on the Shield beautifully.


#16

M.2 SATA storage does not appear to be working either, at least not on the AOSP TV version by @ric96 using my Samsung EVO 850.


#17

host storage should be fixed now
https://bugs.96boards.org/show_bug.cgi?id=501


#18

Awesome. Thanks for that!