SSD loading on USB 3.0 is very slow


#1

Hi all.

I have checked 1 TB external SSD connected to ROCK 960.
Connecting with USB 3.0 is slow, but it connects with USB 2.0 sooner

I use ubuntu 18.04

uname -r
4.4.154-59-rockchip-g5e70f14

II did the following

[connect usb 3.0]

hdparm -tT /dev/sda
/dev/sda:
Timing chaced reads: 2 MB in 61.98 seconds = 33.04 kB/sec
Timing bufferd disk reads: 2 MB in 154.88 seconds = 13.22 kB/sec

[connect usb 2.0]

hdparm -tT /dev/sda
/dev/sda:
Timing chaced reads: 2384 MB in 2.0 seconds = 1192.13 kB/sec
Timing bufferd disk reads: 84 MB in 3.03 seconds = 27.74MB/sec

I am in trouble because I do not know the reason why USB 3.0 is slower than USB 2.0.
Do I need to install somewhere?


#2

Hi, Hiro

Can you run sudo dmesg -c before plug in the SSD, then plug it on the usb3, and run sudo dmesg -c again. Paste the second output here.


#3

Hi hipboi

I tried DMSG as you say

[ 893.899922] usb 4-1: new SuperSpeed USB device number 4 using xhci-hcd
[ 893.920841] usb 4-1: New USB device found, idVendor=0411, idProduct=02c6
[ 893.920874] usb 4-1: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[ 893.920896] usb 4-1: Product: SSD-PGU3/NL
[ 893.920917] usb 4-1: Manufacturer: BUFFALO
[ 893.920937] usb 4-1: SerialNumber: 0040488290204090
[ 893.929623] scsi host1: uas
[ 894.301141] scsi 1:0:0:0: Direct-Access BUFFALO SSD-PGU3/NL 0000 PQ: 0 ANSI: 3
[ 894.301735] xhci-hcd xhci-hcd.9.auto: ERROR Transfer event for disabled endpoint or incorrect stream ring
[ 894.302605] xhci-hcd xhci-hcd.9.auto: @00000000dcdd4520 00000000 00000000 1b000000 01058000
[ 895.745920] sd 1:0:0:0: [sda] 2000409264 512-byte logical blocks: (1.02 TB/954 GiB)
[ 895.776630] sd 1:0:0:0: [sda] Write Protect is off
[ 895.776669] sd 1:0:0:0: [sda] Mode Sense: 73 00 10 08
[ 895.777925] sd 1:0:0:0: [sda] Write cache: enabled, read cache: enabled, supports DPO and FUA
[ 895.778390] xhci-hcd xhci-hcd.9.auto: ERROR Transfer event for disabled endpoint or incorrect stream ring
[ 895.779259] xhci-hcd xhci-hcd.9.auto: @00000000dcdd4670 00000000 00000000 1b000000 01058000
[ 895.791508] xhci-hcd xhci-hcd.9.auto: ERROR Transfer event for disabled endpoint or incorrect stream ring
[ 895.792387] xhci-hcd xhci-hcd.9.auto: @00000000dcdd4790 00000000 00000000 1b000000 01058000
[ 895.801287] xhci-hcd xhci-hcd.9.auto: ERROR Transfer event for disabled endpoint or incorrect stream ring
[ 895.802155] xhci-hcd xhci-hcd.9.auto: @00000000dcdd4900 00000000 00000000 1b000000 01058000
[ 895.802969] sd 1:0:0:0: [sda] Attached SCSI disk


#4

Could you try to disable the UAS and try?

add the following to /etc/modprobe.d/blacklist.conf

blacklist uas

Some usb device firmware is not fully compatible.


#5

Hi hipboi

I added blacklist.conf

blacklist uas

Do the same thing as before,
I run dmesg -c connect usb

usb 4-1: USB disconnect, device number3
usb 4-1: new SuperSpeed USB device number 4 using xhci-hcd
usb 4-1: New USB device found, idVendor=0411, idProduct=02c6
usb 4-1: New USB device strings: Mfr=1, Product=2, SerialNumber=3
usb 4-1: Product: SSD-PGU3/NL
usb 4-1: Manufacturer: BUFFALO
usb 4-1: SerialNumber: 0040488290204090

It was not error.but

sudo fdisk -l

I can’t found my ssd.
and I can’t connect by ssh.

I connect my ssd to USB2.0 port, and run command

sudo fdisk -l

I can found my ssd.
and I can connect by ssh.

It does not go well.