SPI on low speed expansion


#1

I flashed ubuntu 16.04 image. I can’t seem to be able to access SPI on low speed expansion port. I’ve looked at device tree, but can’t figure out which SPI to enable to get the low speed expansion SPI pins working. I tried enabling all the SPI in device tree, but there are conflicts with for access to the ports.

Is there any guidance I can follow?


#2

Hi,

We have merged the pull request from netlhx who is working on the
libmraa with the Seeed Studio grove board.

You can check it here:

We can confirm that spi loop test is working with spi enabled in the
device tree. If you don’t want to build the kernel, Albel has uploaded
the dtb file, just mount /dev/mmcblk1p4(boot partition) and replace
the original rock960-linux.dtb, remember to backup the original one.

Download it here:
https://dl.vamrs.com/users/abel/rock960-linux.dtb


#3

Cheers! Much appreciated @hipboi


#4

@hipboi The loop test works, but lsmod is not showing anything.

I tried some devices that use spi, but they don’t work either.

I tried adding “dtparam=spi=on” to /boot/config.txt, but that does nothing.

I also tried adding spicc, spidev, spi-dev, rk3399-spito /etc/modules, but that does nothing.

Please help.