Some dragonboards no longer boot into bootable micro sd card


#1

Hello folks.

I’m working with a batch of Dragonboards and I’ve been happily booting into a microsd card loaded with debian “dragonboard410c_sdcard_developer_debian-283.img”.

While doing the batch, some of the boards, about 15% just would not boot into the micro sd card. The others worked just fine. I tested it out with multiple sd cards and multiple dragonboards by mixing and matching and only some boards didn’t seem to work with any sd card.

I’m curious, what could be possibly wrong and where can I begin looking?

Thank you!


#2

Have you confirmed that they’re all running the same firmware?


#3

There have been some issues with uSDCard compatability. Fast SD cards don’t run on some boards. I think it is a timing setup issue on the SD controller. We do know that older slow uSDCard always work, but sometimes Class 10 cards don’t work. Have you tried a old and slow uSDCard on the 410c boards that don’t work?

-Lawrence- (no longer a Qualcomm employee)
Actively looking for employment…


#4

Can you describe the nature of this timing issue? I believe that we’re facing a similar phenomenon on our platform with respect to uSDcards and errors like this:

mmcblk1: error -84 transferring data, sector 12591104, nr 8, cmd response 0x900, card status 0xc


#5

Going by the sticker, yes, but I haven’t verified it. I’ll double check once I get a chance.


#6

Unfortunately, I’ve tried it with class 4 and class 10 microsd cards without luck.


#7

I remember an issue with eMMC devices getting wedged in a bad state if they are upgraded using an old release which did not configure the regularors to provide sufficient power for the chip. From this state is not possible to perform SD card based recovery. However a fastboot based recovery should be fine.

It that doesn’t work try installing 18.01 instead of 17.09… my historic notes say “fixed in recent releases (including 18.01)” and I’m not sure if 17,09 is safe in this respect or not.


#8

Hi @Rob_Gries

From memory that looks like it to me. I submitted a bug report on Class10 cards not working. I haven’t checked to see if the bug is fixed now.

Lawrence
Looking for a job…


#9

it is still not fixed.
cheers