Short intro to start your HiKey with serial console


#1

What you need:

Step by step procedure:
(Do not connect your AC adapter yet.)

  • Connect the USB serial adapter or the Mezzanine to the 96Boards.
    Please, please make sure you have not inserted the adapter misaligned on the LS connector.
    It will destroy the both USB serial adapter and the 96Boards later when you power on.
    I know this because I have done this mistake!
  • Connect the MicroUSB cable between your PC and the microUSB connecto on the USB serial adapter or the Mezzanine.
  • Check your 96Boards is not on top of conductive surface.
    For example, MacBook Air has aluminum surface which will short the circuit and damage the 96Boards.
  • Open serial terminal application on your PC.
    The Linux PC has “minicom”.
    On Windows PC, putty or teraterm are well known. Choose any terminal program.
  • Configure the serial port protocol.
    baud rates 11520
    8N1
    Software flow: ON
    Hardware flow: OFF

If the Hardware flow is on, it will hang your screen.

This is the command line if you are using minicom.


sudo minicom -b 115200 -o -D /dev/ttyUSB0


To turn hardware flow off, change the setting by typing on minicom. Ctrl-A -> Z, -> O [Configure Minicom] -> Serial Port Setup -> Options F * Plug your AC adapter and DC plug converter to 96Boards. You will see no LED on the 96Boards but do not panic. You should able to see the power on LED on the USB adapter or the Mezzanine. The boot screen should be showing on your serial console screen. * Have fun. :) * For having more fun, please refer to documentation. https://github.com/96boards/documentation/wiki/HiKey-Home

#2

Thanks


#3

Your small how to is really nice.

This is not clear minicom -b 115200 -o -D /dev/ttyUSB0 has to be issued as root user.

The command with worked for me was:
sudo minicom -b 115200 -o -D /dev/ttyUSB0


#4

Hi @jeeppler,

Thank you for your comment, I just updated the description. :slight_smile:


#5

All working as described. Do you by any chance know how to get past the root login that is being forced when restarting the board afterwards. I think im missing something here.


#6

Fixed it. The above procedure is correct. I was stupid.


#7

How do i get access to the serial console? I have the UART connected to my pc, but when I run the command using minicom as mentioned in the comments, nothing happens.


#8

Are you using a 96boards-uart adapter or something else? If you are using the 96boards-uart adapter how did you configure the jumpers? Do any LEDs flash briefly on the adapter when you type into minicom (the LED is a TX light… if shows us that the PC is talking correctly to the adapter board)?


#9

I’m using this https://www.amazon.com/gp/aw/d/B01ANGB6EO?psc=1&ref=yo_pop_mb_yo_pop_mb_pd_t2
.Interface development board 96 boards . I have connected and the led s are Turning on , but can anyone suggest the steps step by step so that I can follow.


#10

When I do a minicom I get the following result
root@susmitha:/home/susmitha# minicom
Device /dev/tty8 is locked.

Also for some reason , my device PC, doesnt identify the serial ports.

sudo setserial -g /dev/ttyS[01234567]
/dev/ttyS0, UART: unknown, Port: 0x03f8, IRQ: 4
/dev/ttyS1, UART: unknown, Port: 0x02f8, IRQ: 3
/dev/ttyS2, UART: unknown, Port: 0x03e8, IRQ: 4
/dev/ttyS3, UART: unknown, Port: 0x02e8, IRQ: 3
/dev/ttyS4, UART: unknown, Port: 0x0000, IRQ: 0
/dev/ttyS5, UART: unknown, Port: 0x0000, IRQ: 0
/dev/ttyS6, UART: unknown, Port: 0x0000, IRQ: 0
/dev/ttyS7, UART: unknown, Port: 0x0000, IRQ: 0


#11

What do you mean by a TX light ? I have my jumpers as On, OFF, OFF i,e normal boor mode.


#12

Maybe something else is using this tty (other minicom instance) or did not correctly released the tty, you can try to remove the corresponding lock in /var/lock/ and retry.

You are listing ttySX, so how ttyUSB0 can be listed?

On the UART/Serial mezzanine itself, you should see TX and RX leds.


#13

There is an LED on the UART boards labelled TX (short for transmit). It lights up momentarily whenever a character is send from the UART adaptor to the board. It allows you to check that minicom is sending characters to the adaptor.

Sorry, I was talking about the jumpers on the UART adapter. These allow you to switch between LS-UART0 (both jumpers on the UART0 side) and LS-UART1 (both jumpers on the UART1 side).


PS Why are you running minicom with no arguments, that’s not what Akira suggested.


#14

Well I have tried every option i,e under dev I have tried ls |grep ttyUSB . The main thing here is it does not recognize any USB options.


#15

I initially tried using the minicom with parameters, but since nothing is showing up I have tried just the normal minicom.

Regarding the jumpers, are those the three pins which look like spokes , i,e
The one beside the push button.

.

If so , then how do I configure the jumpers.?


#16

Right… and when you are looking at nothing what happens to the TX light when you press keys on the keyboard?

To be honest it might also be useful to have a screenshot of what “nothing” looks like (do you mean a completely blank screen? a blank screen with a black status bar across that bottom?).

Yes.

See p5 of the user guide: https://www.96boards.org/product/uartserial/

What the correct position is depends on your baseboard but setting them for UART1 is by far the most common so try that first.


#17

For some reason It detects my UART when I changed the wire

Now that I have both detected

/dev$ ls |grep ttyU
ttyUSB0
ttyUSB1

And When I run minicom with those parameters I get the following screen

Welcome to minicom 2.7

OPTIONS: I18n
Compiled on Feb 7 2016, 13:37:27.
Port /dev/ttyUSB1, 09:17:33

Press CTRL-A Z for help on special keys
I have followed the steps of changing the settings of hardware flow to off, software flow to on and so on and have exited. But no screen flashes .Its just in the same screen

Also my UART jumpers are set to UART one, and no LED turns on except the Power LED.


#18

The diagnostic that is suggested is that you watch the TX light whilst you also press keys on the keyboard. The TX light will only light up for a very short time when the key first goes down (it does not say on if you hold the key down… although it might start flashing when keyboard auto-repeat happens).

Additionally software flow control should be set to off.


#19

Is this the correct configuration ?

Welcome to minicom 2.7

OPTI±----------------------------------------------------------------------+
Comp| A - Serial Device : /dev/ttyUSB1 |
Port| B - Lockfile Location : /var/lock |
| C - Callin Program : |
Pres| D - Callout Program : |
| E - Bps/Par/Bits : 115200 8N1 |
| F - Hardware Flow Control : No |
| G - Software Flow Control : No |
| |
| Change which setting? |
±----------------------------------------------------------------------+
| Screen and keyboard |
| Save setup as dfl |
| Save setup as… |
| Exit |
±-------------------------+

But I get the to same screen like in the above post. Am I doing anything wrong?


#20

Do I need to have UEFI set up before I actually minicom to the board ?