Serial console problem on HiKey + 96Boards_UART_Adapter_Board

Hi all,
I have used the adapter board and it did well for use of serial console until a couple of days ago.
From a certain time, I could not interact with the console so that it is like just a viewer.
Have anyone experienced this kind of problem?

  • I am using “picocom -b 115200 /dev/ttyUSB0” as a console terminal, on a linux computer.
  • While connected, the console shows correctly all the messages, from the UEFI and to Debian boot …
  • When I type, the RX led of the adapter board blinks. But console looks like being not received any key stroke.


  • I tried to flash the board with 96boards release images and latest snapshot images, several times, but the results are same.
  • I tried to connect from other Windows laptop but the results were same.

Any comment or request for additional info will be welcome.
Thanks in advance.

Hi Hun Jae Lee,

What you have been doing looks fine.

So I only could suspect the release images in the Hikey is not working or
the HiKey or the USB adapter is damaged.

Do you mind teaching us which release you have installed from which download location?

Thanks for your interest.
I have tried so far:


Latest snapshot (as of Apr 18, 2016): (

Additionaly, I tried also u-boot and and open-estuary. Once I could interact with the serial console from all of those instances. But now I can with none.

u-boot download location:

Open-estuary package:

Hi Hun Jae Lee,

Your images flashing on the boards looks fine.

I am also puzzled why your UART stopped working.

Only thing I could think of it now is “Hardware Flow Control” got somehow turned on.
The 96boards will hang the UART when the “Hardware Flow Control” in on,
and must be turned off from your picocom.

Today I found the console responds to my key strokes, but I don’t know why.
I just disconnected all the lines and connected again - power, usb ethernet adapter, the UART board and also PC to the UART board…
Thank you for your kind responses anyway.
If I could identify the causes later, I will let you know.
Thank you again.

Hi Hun Jae Lee,

Happy to know your UART is working again. :slight_smile: