Rock960 A bricked

Need to be able to use the PCIE M.2 connector on this board so I had to update kernel to fix the “PCIe link training gen1 timeout” issue. After following instructions from https://www.96boards.org/documentation/consumer/rock/build/linux-kernel.md.html and rebooting, the box stopped responding. The blue LED doesn’t light up anymore and there is no HDMI signal. The board won’t boot from neither eMMC nor uSD.

The serial output shows NOTICE with BL31 information then garbage characters then the output stops altogether; the system looks to hang at that point.

The usual maskrom instructions never worked for this board: it would never show up in lsusb output no matter what combination of steps or USB-C cables/orientations I used. I checked the buttons electrically, they do make contact.

@hipboi Does the RK option “short the eMMC clock to GND” listed on the Rockchip wiki work for this SBC to force it into maskrom mode? The eMMC is KLMAG1JETD-B041 and I see what looks like 10 semi-exposed pads on 960’s PCB in near proximity of that eMMC chip. Do these correspond to the Dx/CLK/CMD/STRB eMMC lines? If so, which one is CLK?

Anything else I can try to save this board?

Anyone? Based on the Rock 960’s V1.3 schematic EMMC_CLKO is connected to RK3399’s L28 which from the datasheet is not at the ball array edge, so the only way to affect it would be near the eMMC chip or by grounding the R1300 1 resistor (page 9). Can someone help identify exactly which resistor that is? I don’t own an oscilloscope.

Those pads near the eMMC chip could just be positional guideposts, needs confirmation.

Last resort is de-soldering the eMMC chip (to force boot from uSD) which I’d prefer not to do. Based on the serial output the board is currently salvageable, hopefully with as least damage as possible. The fact that the board cannot be seen in MaskROM may point at a hardware issue with the USB-C connector, something 96 eluded to in the other post on this forum about another bricked 960A.

This image seems to confirm that those visible pads would be NC.

I’d really appreciate somebody’s help in determining where exactly on the PCB the resistor R1300 1 is located so that I can try the eMMC CLKO to GND trick to unbrick this SBC.

Thanks to Autodesk for providing a free CAD viewer; I now have all the info I need. EMMC_CLKO is provided on TP4007.

For those who now or in the future encounter issues with entering MaskROM with their Rock960: my board had a manufacturing defect where SW1500 2 was not electrically connected to ground when compared with 96’s schematic. This explains why the button never worked for me - I’d had to use dd instead of rkdeveloptool to write to the eMMC.

There might be an electrical short somewhere or the switch might have not been attached correctly in the factory - in fact, I tried gently lifting that side of the switch from the board and there was a tiny bit of play.

In this case the permanent fix was to manually connect SW1500 2 to GND. I used a 30 AWG wire.

You need a fine soldering iron tip and a steady hand, there are tiny resistors very nearby.

The board is now unbricked.

Those are not exactly the best quality boards, but congrats on getting it working.