Replacement for telent for uefi via uart


#1

on this page https://github.com/96boards-hikey/tools-images-hikey960/blob/master/build-from-source/README-ATF-UEFI-build-from-source.md

It is recommended not to use minicom as “Use telnet as the console since UEFI will output window that fails to display in minicom”

I’ve had issues with telnet including telnet: connect to address 127.0.0.1: Connection refused … etc, which, i’ve done everything found and I’m don’t really want to spend a lot of time into it.

so i am looking for a suitable alternative that can display uefi properly, possibly a cli based tool…
thanks


#2

I think if you don’t have a need to press Esc to go to the UEFI window, then you might be able to get away with just using minicom.

For the refused connections, have you tried restarting ser2net? I.e. sudo killall ser2net; sudo ser2net -u?


#3

I use picocom with all my systems, including EUFI ones.

Tools like grub do tend to mess up the terminal emulator state a little
by setting a different background/foreground and not restore normality.
Happily the colourful logs as systemd boots do tend to restore things to
normal.


#4

@vchong I’ve tried everything, including restarting using systemctl and rebooting the system

@danielt thanks, picocom works perfectly for me