Problems following instructions for installing UEFI


#1

After following the instructions to build and flash UEFI (at https://github.com/96boards/documentation/wiki/HiKeyUEFI") I get to the point of loading the new loader and see:

Switch to aarch64 mode. CPU0 executes at 0xf9801000!

on the serial console. and

fastboot flash ptable ptable-linux.img 
sending 'ptable' (17 KB)... FAILED (remote: invalid partition)

What am I doing wrong?


#2

Recent UEFI builds have moved the serial output from the (unpopulated) 4 pin header to the LS connector.

Try hooking up your UART to the UART1 pins on the LS connector.

Note that the UART1 pins are labeled UART3 in the HiKey hardware manual. LS UART0 and LS UART1 pins are connected to HI6220’s second and third UARTs hence both set of numbers can be correct at the same time ;-). Whatever number you use for the UART you need to connect to pins 11 and 13 on the LS connector.


#3

I don’t think that’s the problem. The problem arises trying to flash the partition table, before the UEFI boot partition has been flashed. The fastboot software invoked by l-loader doesn’t seem to know about the ptable partition.

The output from

fastboot flash ptable ptable-linux.img

is

sending 'ptable' (17 KB)... FAILED (remote: invalid partition)

#4

I just tried following the instructions and had no problems running them.
Are you using the latest prebuilt binaries?
Have you checked their md5sums to make sure they were downloaded properly?
Are the jumper pins in the proper position?
Any other info you can provide?


#5

I’ve worked it out. The version of the fastboot tool I was using had been hacked to work with the IFC6410 baord, and was doing bad things to the protocol. Switching to upstream fastboot fixed the matter.

Thanks for all the help!