Problem with UART4/UART1


Having trouble with UART4. Using Debian stretch image from the downloads section on an sdcard. UART4 or ttyS2 i believe doesn’t seem to be working.

dmesg | grep tty returns

[ 0.000000] Kernel command line: earlyprintk console=ttyFIQ0,1500000n8 rw root=PARTUUID=b921b045-1d rootfstype=ext4 init=/sbin/init rootwait
[ 0.136627] Registered FIQ tty driver
[ 0.218979] console [ttyFIQ0] enabled
[ 0.219484] Registered fiq debugger ttyFIQ0
[ 0.986006] ff180000.serial: ttyS0 at MMIO 0xff180000 (irq = 36, base_baud = 1500000) is a 16550A
[ 0.987405] ff1a0000.serial: ttyS2 at MMIO 0xff1a0000 (irq = 37, base_baud = 1500000) is a 16550A

Looks good to me. But when i run something like this

stty -F /dev/ttyS2 -a
I get
stty: /dev/ttyS2: Input/output error

When I run it for ttyS0
stty -F /dev/ttyS0 -a
I get the info for the port
speed 9600 baud; rows 0; columns 0; line = 0;
intr = ^C; quit = ^; erase = ^?; kill = ^U; eof = ^D; eol = ; eol2 = ; swtch = ; start = ^Q; stop = ^S; susp = ^Z; rprnt = ^R;
werase = ^W; lnext = ^V; discard = ^O; min = 1; time = 0;
-parenb -parodd -cmspar cs8 hupcl -cstopb cread clocal -crtscts
-ignbrk -brkint -ignpar -parmrk -inpck -istrip -inlcr -igncr icrnl ixon -ixoff -iuclc -ixany -imaxbel -iutf8
opost -olcuc -ocrnl onlcr -onocr -onlret -ofill -ofdel nl0 cr0 tab0 bs0 vt0 ff0
isig icanon iexten echo echoe echok -echonl -noflsh -xcase -tostop -echoprt echoctl echoke -flusho -extproc

At a loss as to why it would show up in dmesg but not be available to configure. Any help would be greatly appreciated.


I suggest you update to the latest rockchip 4.4 kernel first:

You need to install the linux-image-4.4.154-83-rockchip package.


Thanks for the help. I’ve been trying to get the updated kernel installed but having trouble. I installed the updated kernel image package. But the updated kernel does not load at boot. Using uname I still get the old kernel. So I’m thinking I need to change uboot to load the updated kernel image(Had to wait for the vamrs usb to serial adaptor to arrival so I could get into the console). I’m new to using uboot and trying to learn about it. I’m used to grub2. Do I need to use mkimage to make a uImage out of the image that was installed? If no, How do I go about getting this image to load at boot?



You can edit your /boot/extlinux/extlinux.conf and check the “boot menu”, which is kind of like grub but the message is on the serial console. You can choose which kernel to boot from the serial console.