Painfully slow Wif on 410c wcn36xx


#1

Hi Folks:
Installed Linaro Ubuntu 15.09 ( also tried 15.06 ) and unable to get wlan0 to anything above 1Mb/sec.
Not seeing a wcn36xx.conf modules file, updated the WCNSS_qcom_cfg.init driver file but no change ( does module need to be recompiled? ). Any thoughts on boosting this performance? AP is known good, have 3 other hosts ( Win/Linux ) using it at 54Mb/sec, would like to get the 410c to do the same ( or better ).

config, dmesg wcn36xx references below.

Thanks

linaro@linaro-alip:/$ sudo find . -type f -name “WCN*” -exec file {} ; | egrep -i -v ‘(exec|bin)’
./lib/firmware/wlan/prima/WCNSS_cfg.dat: data
./lib/firmware/wlan/prima/WCNSS_qcom_cfg.ini: ASCII text
./lib/firmware/wlan/prima/WCNSS_wlan_dictionary.dat: ASCII text, with CRLF line terminators
linaro@linaro-alip:/$ iwconfig wlan1
wlan1 IEEE 802.11abgn ESSID:"Homey2"
Mode:Managed Frequency:2.457 GHz Access Point: 84:1B:5E:51:35:3F
Bit Rate=1 Mb/s Tx-Power=20 dBm
Retry short limit:7 RTS thr:off Fragment thr:off
Power Management:off
Link Quality=42/70 Signal level=-68 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:1 Missed beacon:0

linaro@linaro-alip:/$ nmcli d wifi list

  • SSID MODE CHAN RATE SIGNAL BARS SECURITY
    ATT6iG3z3A Infra 11 54 Mbit/s 59 ▂▄▆_ WPA1 WPA2
    myjazzi Infra 4 54 Mbit/s 19 ▂___ WPA1 WPA2
    Howdy Infra 1 54 Mbit/s 7 ▂___ WPA1 WPA2
    HP-Print-2A-Officejet 4630 Infra 1 54 Mbit/s 5 ____ WPA2
    Howdy-guest Infra 1 54 Mbit/s 5 ____ –
  • Homey2 Infra 10 54 Mbit/s 60 ▂▄▆_ WPA2

Dmesg:
linaro@linaro-alip:/$ dmesg | grep -i wcn36 | more
[ 5.762379] msm8916-pinctrl 1000000.pinctrl: request pin 40 (GPIO_40) for a000000.qcom,wcn36xx
[ 5.762395] msm8916-pinctrl 1000000.pinctrl: request pin 41 (GPIO_41) for a000000.qcom,wcn36xx
[ 5.762409] msm8916-pinctrl 1000000.pinctrl: request pin 42 (GPIO_42) for a000000.qcom,wcn36xx
[ 5.762423] msm8916-pinctrl 1000000.pinctrl: request pin 43 (GPIO_43) for a000000.qcom,wcn36xx
[ 5.762436] msm8916-pinctrl 1000000.pinctrl: request pin 44 (GPIO_44) for a000000.qcom,wcn36xx
[ 9.284157] wcn36xx-msm a000000.qcom,wcn36xx: wcn36xx_msm_probe initialized
[ 9.317643] wcn36xx wcn36xx: no of_node; not parsing pinctrl DT
[ 9.318420] wcn36xx wcn36xx: Direct firmware load for wlan/macaddr0 failed with error -2
[ 9.318434] wcn36xx wcn36xx: Falling back to user helper
[ 69.337549] wcn36xx wcn36xx: Failed (-11) to read macaddress file wlan/macaddr0, using a random address instead
[ 69.337672] wcn36xx: mac address: 00:0a:f5:82:4c:24
[ 69.517136] wcn36xx wcn36xx wlan1: renamed from wlan0
[ 69.969044] wcn36xx: firmware WLAN version ‘WCN v2.0 RadioPhy vRhea_GF_1.12 with 19.2MHz XO’ and CRM version ‘CNSS-PR-2-0-1-2-c1-
00010’
[ 69.969077] wcn36xx: firmware API 1.5.1.2, 41 stations, 2 bssids
[ 69.972144] wcn36xx: FW Cap MCC
[ 69.972167] wcn36xx: FW Cap P2P
[ 69.972183] wcn36xx: FW Cap SLM_SESSIONIZATION
[ 69.972198] wcn36xx: FW Cap DOT11AC_OPMODE
[ 69.972212] wcn36xx: FW Cap SAP32STA
[ 69.972227] wcn36xx: FW Cap TDLS
[ 69.972241] wcn36xx: FW Cap P2P_GO_NOA_DECOUPLE_INIT_SCAN
[ 69.972255] wcn36xx: FW Cap WLANACTIVE_OFFLOAD
[ 69.972269] wcn36xx: FW Cap BEACON_OFFLOAD
[ 69.972283] wcn36xx: FW Cap SCAN_OFFLOAD
[ 69.972297] wcn36xx: FW Cap BCN_MISS_OFFLOAD
[ 69.972312] wcn36xx: FW Cap STA_POWERSAVE
[ 69.972326] wcn36xx: FW Cap STA_ADVANCED_PWRSAVE
[ 69.972340] wcn36xx: FW Cap BCN_FILTER
[ 69.972354] wcn36xx: FW Cap RTT
[ 69.972367] wcn36xx: FW Cap RATECTRL
[ 69.972381] wcn36xx: FW Cap WOW
[ 69.972395] wcn36xx: FW Cap WLAN_ROAM_SCAN_OFFLOAD
[ 69.972410] wcn36xx: FW Cap SPECULATIVE_PS_POLL
[ 69.972424] wcn36xx: FW Cap IBSS_HEARTBEAT_OFFLOAD
[ 69.972438] wcn36xx: FW Cap WLAN_SCAN_OFFLOAD
[ 69.972452] wcn36xx: FW Cap WLAN_PERIODIC_TX_PTRN
[ 69.972466] wcn36xx: FW Cap ADVANCE_TDLS
[ 69.972480] wcn36xx: FW Cap BATCH_SCAN
[ 69.972493] wcn36xx: FW Cap FW_IN_TX_PATH
[ 69.972507] wcn36xx: FW Cap EXTENDED_NSOFFLOAD_SLOT
[ 69.972521] wcn36xx: FW Cap CH_SWITCH_V1
[ 69.972535] wcn36xx: FW Cap HT40_OBSS_SCAN
[ 69.972549] wcn36xx: FW Cap UPDATE_CHANNEL_LIST
[ 69.972563] wcn36xx: FW Cap UNKNOWN
[ 69.972576] wcn36xx: FW Cap UNKNOWN
[ 69.972590] wcn36xx: FW Cap UNKNOWN
[ 69.972603] wcn36xx: FW Cap UNKNOWN
[ 69.972617] wcn36xx: FW Cap UNKNOWN
[ 69.972630] wcn36xx: FW Cap UNKNOWN
[ 69.972644] wcn36xx: FW Cap UNKNOWN
[ 69.972658] wcn36xx: FW Cap UNKNOWN
[ 69.972671] wcn36xx: FW Cap UNKNOWN
[ 69.972684] wcn36xx: FW Cap UNKNOWN
[ 70.024925] wcn36xx: CSR_RESET: 0x10001
linaro@linaro-alip:/$


#2

Timmy527, could you please share how you measure the average speed?
Through simple download (wget and aria2), I tend to be getting a little
above 2MiB/s. On my Linux desktop with the same download, I get above
9MiB/s.


#3

If you have a linux box on the same network, could you execute:

user@dragon > iperf -s
user@box    > iperf -c  dragon_ip

and report that number please?


#4

Hi Folks:
Used wget and scp to download/copy some larger ( 25MB ) files.
Download rate typically ranged from 200 - 400Kb/sec, upload rate was closer to the 1Mb/sec.
Painfully slow…

  I'll run the iperf stats when I get home but just looking for details on how to boost/config this 
  driver.

Thx


#5

Also, note that hosts connecting to the same AP saw same signal strength and negotiated upwards of 54Mb/sec, and consequently saw considerably faster download/upload speeds.


#6

I am measuring 22 Mbits/sec on release 15.07.

Using exactly same setup I measured 27.7 Mbits/sec on a lenovo x220 running ubuntu 14.04.


#7

I am sometimes seeing problems (slow or delays) with my wireless, but isolated tests (iperf) show good performance (25-30Mbits/sec). I have noticed in the system log that I am receiving lots of:

Oct 26 22:10:34 localhost.localdomain kernel: wcn36xx: ERROR SMD_EVENT (259) not supported
Oct 26 22:11:40 localhost.localdomain kernel: wcn36xx: ERROR SMD_EVENT (259) not supported
Oct 26 22:12:52 localhost.localdomain kernel: wcn36xx: ERROR SMD_EVENT (259) not supported
Oct 26 22:13:53 localhost.localdomain kernel: wcn36xx: ERROR SMD_EVENT (259) not supported
Oct 26 22:15:32 localhost.localdomain kernel: wcn36xx: ERROR SMD_EVENT (259) not supported
Oct 26 22:17:00 localhost.localdomain kernel: wcn36xx: ERROR SMD_EVENT (259) not supported
Oct 26 22:18:00 localhost.localdomain kernel: wcn36xx: ERROR SMD_EVENT (259) not supported
Oct 26 22:19:46 localhost.localdomain kernel: wcn36xx: ERROR SMD_EVENT (259) not supported

and every couple of minutes I see:

Oct 26 18:02:24 localhost.localdomain kernel: wlan0: deauthenticated from 44:94:fc:53:ca:fc (Reason: 7=CLASS3_FRAME_FROM_NONASSOC_STA)
Oct 26 18:02:25 localhost.localdomain kernel: wlan0: authenticate with 44:94:fc:53:ca:fc
Oct 26 18:02:25 localhost.localdomain kernel: wlan0: send auth to 44:94:fc:53:ca:fc (try 1/3)
Oct 26 18:02:25 localhost.localdomain kernel: wlan0: authenticated
Oct 26 18:02:25 localhost.localdomain kernel: wlan0: associate with 44:94:fc:53:ca:fc (try 1/3)
Oct 26 18:02:25 localhost.localdomain kernel: wlan0: RX AssocResp from 44:94:fc:53:ca:fc (capab=0x411 status=0 aid=3)
Oct 26 18:02:25 localhost.localdomain kernel: wlan0: associated

I’m not sure if anyone else is experiencing this, or if it is a known issue, but I was curious if it could be affecting performance. I am not using wireless from my workstation, so I don’t have a lot of experience with wireless on this router, but the frequency of these messages seems cause for concern, unless they are just ‘debugging’ messages left on in this kernel (4.2.0-linaro-lt-qcom #1 SMP PREEMPT Thu Oct 15 15:24:52 UTC 2015 aarch64).


#8

I should have read more before posting. I see the ‘wcn36xx: ERROR SMD_EVENT (259) not supported’ messages are a known issue:

https://bugs.96boards.org/show_bug.cgi?id=120

and not something that would affect performance.


#9

Hi guys,
I tried to reproduce this problem in my side. But can’t hit the slow throughput issue. I kept
the Dragonboard running for two days and test the throughput by downloading a file by using
ftp from another Linux box periodically. The ftp throughput is about 5.92MiB/s:
lftp fyin@20.0.0.12:~/video> get virtio-vsock-\ Zero-configuration\ host-guest\ communication\ by\ Stefan\ Hajnoczi.mp4
361076395 bytes transferred in 58 seconds (5.92 MiB/s)

BTW, my AP is very close to my Dragonboard. Not sure whether it matters.

Regards
Yin, Fengwei


#10

The message “Oct 26 22:19:46 localhost.localdomain kernel: wcn36xx: ERROR SMD_EVENT (259) not supported” shouldn’t impact the throughput.

The message “Oct 26 18:02:24 localhost.localdomain kernel: wlan0: deauthenticated from 44:94:fc:53:ca:fc (Reason: 7=CLASS3_FRAME_FROM_NONASSOC_STA)” means the connection was shutdown by AP. There are many reasons triggering it.
And yes, this could impact the wifi throughput.


#11

Hi Folks:
Reimaged the 410c with Android ( release 15.9 ) and connected with the same AP at 72Mb/sec rate. Througput in/out ( downloads/uploads ) is significantly faster. This should rule out the HW as the curlprit. Any suggestiongs on how to this host to negotiate to a higher data rate with the AP when it’s running Ubuntu?

Thx


#12

Could you please show how you measure the wireless throughput?


#13

Measured throughput with Browser downloads from remote and local hosts.
From remote hosts ( linero/google ) was seeing almost wire speed up/down through the cable modem, from local hosts
was seeing almost 10MB/sec ( ~80Mb/sec ) in both directions.

Granted the Android tests were not extremely thorough but the bigger interest is how do
I get the Ubuntu AP connection to be something over 1Mb/sec data rate, as mentioned the Android AP connection data rate was 72Mb/sec. The Ubuntu host is not going to push much data if the only data rate is knows is 1Mb/sec.

The issue I’m trying to solve is pushing the wifi data rate on the Ubuntu host higher than the 1Mb/sec that’s stated as the negotiated rate in ifconfig. Surrounding hosts are negotiating significantly higher rates on the same AP.

Thx


#14

Thanks for the information.

Again, I got 5.92MiB/s (~48Mb/sec) in my side with Ubuntu 15.09. But I have AP very close to dragonboard.
And it’s very stable in my two days testing.

Did you see the deauthenticated info a lot like dmarlin?


#15

I’ve got the same problem and don’t know how to resolve it.

Anybody has a solution.

thanks


#16

One more question: do you use BT with wifi together? If I use BT with wifi together in my side, I got very bad wifi throughput. If I only have wifi, the throughput is about 6MB/s.


#17

At this moment I don’t use BT due that I received DB410C only two weeks ago. I solved several problems but Wifi connection still at 1 Megabit/s (max. throughput less than 100 Kbytes/s). I tried with four different Wifi connections (with distinct wifi routers and providers) and DB410c doesn’t connect. When connects the bit rate its only at 1 Mb/s.

I read in some linaro blogs that could be a bug and try different solutions, but the problem still persistent.