ORB_SLAM on Dragonboard 410c


#1

Hi,
I am going to run ORB_SLAM on db 410c, and the compilation will always stop when compiling g2o.
How can I run ORB_SLAM on Linaro Debian?


#2

hi,

I don’t know much about the tools you are mentioning. I would recommend to check first that these tools support ‘debian’ in general and ARM, and if they do, please provide more information about the compilation issues you are facing. Maybe a compiler log can bring us a bell about what issue you are facing.


#3

Hi

I presume you have Eigen installed first to compile g2o?

Would be helpful if you can share the logs and memory footprint?

Thanks


#4

Hi, sorry for late reply.
I was using linaro Debian 16.09 at first and there is a error:
unknow value ‘native’ for -march
I guess there is some problem with C++11, and linaro Debian 17.04 was released at that time, so I turned to the latest version and there is no error in compilation, but the board will stop working during compilation. I can not even move the mouse.
The log looks like:
[3%] …
[6%] …
[10%] Building CXX object CMakeFiles/g2o.dir/g2o/types/types_seven_dof_expmap.cpp.o
I tried several times and waited for over half an hour, but the program did not work again.
Any suggestion?
Thanks in advance.


#5

Hi, sorry for late reply.
I have installed Eigen and other libraries before compilation.
You can see the log in the forum before and the memory in use will keep high during compilation. When the board stop working, the memory footprint will stop recording.
Any suggestion?
Thank in advance.


#6

Memory use! How high is high?

Also does the build system support a parallel make? If so this needs to be disabled… for complex C++ code the board only has really enough RAM to support a single compiler at once (maybe not even that much).


#7

for ‘complex’ compilation you might hit the kernel OOM killer. to reduce memory usage i recommend to disable/stop the desktop (in case it’s running), by running:

systemctl isolate multi-user.target

Also, adding a swap file or partition might help avoiding the OOM killer, but if you really need a lot of memory, it won’t crash, but it might take forever…


#8

Hi,
I have tried compiling g2o with ‘make’ instead of ‘make -j’.
For the memory use, it will be up to over 80% before the program stops.
Thanks in advance.


#9

Thank you for your advice , and I will try it later.