No HDMI after apt-get upgrade


#1

Hi,

I just installed the latest debian release ( #359-7f00b150) on my dragonboard 410c via fastboot and everything went very well so far. However, after performing sudo apt-get update and upgrade (or dist-upgrade, all the same) and rebooting the board HDMI didn’t work any longer.
Any idea how to fix this?


#2

I am just curious as I have had a similar experience with a DB820c which is currently unresolved:


What kernel version were you running previously that worked?
Do you have another monitor that works?
What version of HDMI does your monitor support? Mine supports only 1.4.

Perhaps I replied too quickly. I just reread your post and see that it was an apt-get update that gave you the problem so it is probably different to my problem.
Your problem could simply be that the apt-get updated the kernel modules or some other package the kernel is dependent on.


#3

@Guzzibutz It seems the issue is related to https://bugs.96boards.org/show_bug.cgi?id=744. Re-flashing image could be a quick solution.


#4

Good idea - but where to get the kernel image that fits to the kernel modules in my rootfs?


#5

The mentioned workaround seemed to help! I executed
sudo apt-mark hold linux-image-4.14.0-qcomlt-arm64
before performing dist-upgrade and did not get any error anymore, even HDMI works well


#6

AFAIK, new kernel is downloaded at /boot/vmlinuz-4.14.0-qcomlt-arm64, but the one which is loaded by the bootloader is located in the boot partition (boot image). So you need to inject the new kernel in the bootimg. You can use dbootimg tool (from you board console):

git clone https://github.com/96boards/dt-update.git
cd dt-update
make
make install
dbootimg /dev/disk/by-partlabel/boot -u kernel /boot/vmlinuz-4.14.0-qcomlt-arm64
reboot

Let me know…


Bootloader with UFS support
#7

Very nice. This one helped as well and I could fix my broken dragonboard linux installation. Thanks a lot!


#8

This worked also in my case, an newby DragonBoard 401 student struggling for a week, of flashing a new Debian image on EMMC, after which sudo upgrade led to the “no HDMI after apt-get upgrade”. The following "Loic"approach I am also going to try. Thanks!